CVE-2005-2042
CVSS4.3
发布时间 :2005-06-16 00:00:00
修订时间 :2008-09-05 16:50:43
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in ajax-spell before 1.8 allows remote attackers to inject arbitrary web script or HTML via onmouseover or other events in HTML tags.


[CNNVD]ajax-spell 跨站脚本攻击漏洞(CNNVD-200506-141)

        ajax-spell 1.8之前版本中存在跨站脚本攻击(XSS)漏洞,远程攻击者可借助HTML标识符中的onmouseover或其它事件注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ajax-spell:ajax-spell:1.4
cpe:/a:ajax-spell:ajax-spell:1.1
cpe:/a:ajax-spell:ajax-spell:1.2
cpe:/a:ajax-spell:ajax-spell:1.6
cpe:/a:ajax-spell:ajax-spell:1.5
cpe:/a:ajax-spell:ajax-spell:1.7
cpe:/a:ajax-spell:ajax-spell:1.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2042
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2042
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-141
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/13986
(PATCH)  BID  13986
http://www.broken-notebook.com/spell_checker/index.php
(VENDOR_ADVISORY)  CONFIRM  http://www.broken-notebook.com/spell_checker/index.php
http://sourceforge.net/project/shownotes.php?release_id=335556
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=335556
http://secunia.com/advisories/15737
(VENDOR_ADVISORY)  SECUNIA  15737

- 漏洞信息

ajax-spell 跨站脚本攻击漏洞
中危 跨站脚本
2005-06-16 00:00:00 2005-10-20 00:00:00
远程  
        ajax-spell 1.8之前版本中存在跨站脚本攻击(XSS)漏洞,远程攻击者可借助HTML标识符中的onmouseover或其它事件注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        ajax-spell ajax-spell 1.1
        ajax-spell ajax-spell 1.9
        http://sourceforge.net/project/showfiles.php?group_id=141511&package_id=155305
        ajax-spell ajax-spell 1.2
        ajax-spell ajax-spell 1.9
        http://sourceforge.net/project/showfiles.php?group_id=141511&package_id=155305
        ajax-spell ajax-spell 1.3
        ajax-spell ajax-spell 1.9
        http://sourceforge.net/project/showfiles.php?group_id=141511&package_id=155305
        ajax-spell ajax-spell 1.4
        ajax-spell ajax-spell 1.9
        http://sourceforge.net/project/showfiles.php?group_id=141511&package_id=155305
        ajax-spell ajax-spell 1.5
        ajax-spell ajax-spell 1.9
        http://sourceforge.net/project/showfiles.php?group_id=141511&package_id=155305
        ajax-spell ajax-spell 1.6
        ajax-spell ajax-spell 1.9
        http://sourceforge.net/project/showfiles.php?group_id=141511&package_id=155305
        ajax-spell ajax-spell 1.7
        ajax-spell ajax-spell 1.9
        http://sourceforge.net/project/showfiles.php?group_id=141511&package_id=155305

- 漏洞信息

17416
AJAX Spell Checker (ajax-spell) XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

AJAX Spell Checker contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the content of onmouseover or other event tags. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-06-17 Unknow
Unknow 2005-06-16

- 解决方案

Upgrade to version 1.9 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站