CVE-2005-2021
CVSS4.3
发布时间 :2005-06-20 00:00:00
修订时间 :2008-09-05 16:50:40
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in cPanel 9.1 and earlier allows remote attackers to inject arbitrary web script or HTML via the user parameter in the login page.


[CNNVD]cPanel 'user'参数 跨站脚本攻击漏洞(CNNVD-200506-185)

        cPanel 9.1及早期版本中存在跨站脚本攻击(XSS)漏洞, 远程攻击者可以借助登录页面中的user 参数,注入任意 web脚本或HTML 。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:cpanel:cpanel:9.1
cpe:/a:cpanel:cpanel:6.4.1
cpe:/a:cpanel:cpanel:5.3
cpe:/a:cpanel:cpanel:6.2
cpe:/a:cpanel:cpanel:8.0
cpe:/a:cpanel:cpanel:6.4.2_stable_48
cpe:/a:cpanel:cpanel:6.4
cpe:/a:cpanel:cpanel:6.0
cpe:/a:cpanel:cpanel:6.4.2
cpe:/a:cpanel:cpanel:5.0
cpe:/a:cpanel:cpanel:7.0
cpe:/a:cpanel:cpanel:9.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2021
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-2021
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-185
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/13996
(VENDOR_ADVISORY)  BID  13996

- 漏洞信息

cPanel 'user'参数 跨站脚本攻击漏洞
中危 跨站脚本
2005-06-20 00:00:00 2005-10-20 00:00:00
远程  
        cPanel 9.1及早期版本中存在跨站脚本攻击(XSS)漏洞, 远程攻击者可以借助登录页面中的user 参数,注入任意 web脚本或HTML 。

- 公告与补丁

        暂无数据

- 漏洞信息

17399
cPanel cpsrvd.pl user Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

cPanel contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'user' variable upon submission to the 'cpsrvd.pl' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-06-22 Unknow
2005-06-22 Unknow

- 解决方案

Upgrade to version 10.2.0 (build 210) or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站