CVE-2005-1996
CVSS5.0
发布时间 :2005-06-15 00:00:00
修订时间 :2016-10-17 23:23:47
NMCO    

[原文]PHP remote file inclusion vulnerability in start.php in Bitrix Site Manager 4.0.x allows remote attackers to execute arbitrary PHP code via the _SERVER[DOCUMENT_ROOT] parameter.


[CNNVD]Bitrix Site Manager 'start.php'脚本 PHP远程文件包含漏洞(CNNVD-200506-134)

        Bitrix Site Manager 4.0.x 中的start.php脚本存在PHP远程文件包含漏洞,远程攻击者可以借助_SERVER[DOCUMENT_ROOT]参数来执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)

cpe:/a:bitrix:bitrix_site_manager:4.0.8
cpe:/a:bitrix:bitrix_site_manager:4.0.7
cpe:/a:bitrix:bitrix_site_manager:4.0.6
cpe:/a:bitrix:bitrix_site_manager:4.0.5
cpe:/a:bitrix:bitrix_site_manager:4.0.4
cpe:/a:bitrix:bitrix_site_manager:4.0.3
cpe:/a:bitrix:bitrix_site_manager:4.0.2
cpe:/a:bitrix:bitrix_site_manager:4.0.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1996
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1996
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-134
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111885605913761&w=2
(UNKNOWN)  BUGTRAQ  20050615 Vulnerability: Bitrix Php inclusion
http://www.bitrixsoft.com/sitemanager/versions.php?module=main
(PATCH)  CONFIRM  http://www.bitrixsoft.com/sitemanager/versions.php?module=main
http://www.bitrixsoft.com/support/forum/read.php?FID=10&TID=1872
(PATCH)  CONFIRM  http://www.bitrixsoft.com/support/forum/read.php?FID=10&TID=1872
http://www.securityfocus.com/bid/13965
(UNKNOWN)  BID  13965
http://www.vupen.com/english/advisories/2005/0779
(VENDOR_ADVISORY)  VUPEN  ADV-2005-0779
http://xforce.iss.net/xforce/xfdb/21018
(UNKNOWN)  XF  bitrix-serverdocumentroot-file-include(21018)

- 漏洞信息

Bitrix Site Manager 'start.php'脚本 PHP远程文件包含漏洞
中危 代码注入
2005-06-15 00:00:00 2006-09-27 00:00:00
远程  
        Bitrix Site Manager 4.0.x 中的start.php脚本存在PHP远程文件包含漏洞,远程攻击者可以借助_SERVER[DOCUMENT_ROOT]参数来执行任意PHP代码。

- 公告与补丁

        

- 漏洞信息

17341
Bitrix Site Manager index.php _SERVER[DOCUMENT_ROOT] Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Bitrix contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to index.php not properly sanitizing user input supplied to the _SERVER[DOCUMENT_ROOT] variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2005-06-15 Unknow
2005-06-15 Unknow

- 解决方案

Upgrade to version 4.09 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站