CVE-2005-1966
CVSS7.5
发布时间 :2005-06-10 00:00:00
修订时间 :2016-10-17 23:23:40
NMCOS    

[原文]The eTrace_validaddr function in eTrace plugin for e107 portal allows remote attackers to execute arbitrary commands via shell metacharacters after a valid argument to the etrace_host parameter.


[CNNVD]e107 eTrace_validaddr函数 任意命令执行漏洞(CNNVD-200506-101)

        e107系统的eTrace插件中的eTrace_validaddr函数存在漏洞,远程攻击者可借助在etrace_host参数的一个有效自变量后的shell元字符来执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1966
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1966
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-101
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111868460811287&w=2
(UNKNOWN)  BUGTRAQ  20050610 Re: Arbitrary code execution in eping plugin
http://www.securityfocus.com/bid/13934
(VENDOR_ADVISORY)  BID  13934

- 漏洞信息

e107 eTrace_validaddr函数 任意命令执行漏洞
高危 输入验证
2005-06-10 00:00:00 2005-10-20 00:00:00
远程  
        e107系统的eTrace插件中的eTrace_validaddr函数存在漏洞,远程攻击者可借助在etrace_host参数的一个有效自变量后的shell元字符来执行任意命令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        e107.org eTrace 1.0 1
        e107 eTrace 1.03
        http://e107plugins.co.uk/request.php?6
        e107.org eTrace 1.0 2
        e107 eTrace 1.03
        http://e107plugins.co.uk/request.php?6

- 漏洞信息

20515
e107 eTrace etrace_host Parameter Arbitrary Command Execution

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-06-10 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

e107 eTrace Remote Command Execution Vulnerability
Input Validation Error 13934
Yes No
2005-06-10 12:00:00 2009-07-12 02:56:00
Discovery is credited to Oliver Monneke <oliver@codersquad.de>.

- 受影响的程序版本

e107.org eTrace 1.0 2
e107.org eTrace 1.0 1
e107.org ePing 1.0 1
e107.org eTrace 1.0 3

- 不受影响的程序版本

e107.org eTrace 1.0 3

- 漏洞讨论

eTrace is prone to a remote command execution vulnerability.

Due to this, an attacker can supply arbitrary shell commands and have them executed in the context of the server. This can facilitate various attacks including unauthorized access to an affected computer.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has released version 1.03 to address this issue:


e107.org eTrace 1.0 1

e107.org eTrace 1.0 2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站