CVE-2005-1955
CVSS4.3
发布时间 :2005-06-12 00:00:00
修订时间 :2016-10-17 23:23:36
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in index.php in singapore 0.9.11 allows remote attackers to inject arbitrary web script or HTML via the gallery parameter.


[CNNVD]Singapore Image Gallery 'Index.PHP'跨站脚本漏洞(CNNVD-200506-107)

        singapore 0.9.11中的index.php脚本存在跨站脚本攻击(XSS)漏洞,远程攻击者可借助gallery参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1955
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1955
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-107
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111868634003167&w=2
(UNKNOWN)  BUGTRAQ  20050612 singapore v0.9.11 cross site scripting and path disclosure
http://securitytracker.com/id?1014186
(UNKNOWN)  SECTRACK  1014186
http://www.securityfocus.com/bid/13938
(UNKNOWN)  BID  13938

- 漏洞信息

Singapore Image Gallery 'Index.PHP'跨站脚本漏洞
中危 跨站脚本
2005-06-12 00:00:00 2005-10-20 00:00:00
远程  
        singapore 0.9.11中的index.php脚本存在跨站脚本攻击(XSS)漏洞,远程攻击者可借助gallery参数注入任意Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

17338
Singapore index.php $_GET Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

singapore contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate '$_GET' variables upon submission to the 'index.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-06-12 Unknow
2005-06-12 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Singapore Image Gallery Index.PHP Cross-Site Scripting Vulnerability
Input Validation Error 13938
Yes No
2005-06-13 12:00:00 2009-07-12 02:56:00
thegreatone2176 <thegreatone2176@yahoo.com> is credited with the discovery of this vulnerability.

- 受影响的程序版本

singapore singapore 0.9.11 beta

- 漏洞讨论

Singapore image gallery is prone to a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

No exploit is required.

The following proof of concept URI is available:
http://www.example.com/index.php?gallery=%3Cimg%20onmouseover=%22alert('hi')%22%20style=%22position:%20absolute;%20top:0px;%20left:%200px;%20width:%201000%;%20height:%201000%;%22%3E

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站