发布时间 :2005-06-09 00:00:00
修订时间 :2016-10-17 23:23:28

[原文]Multiple SQL injection vulnerabilities in Invision Gallery before 1.3.1 allow remote attackers to execute arbitrary SQL commands via (1) the comment parameter in an editcomment action or (2) the rating parameter when voting on a photo.

[CNNVD]Invision Gallery SQL注入漏洞(CNNVD-200506-069)

        Invision Gallery 1.3.1之前的版本中存在多个SQL注入漏洞,远程攻击者可借助:(1)editcomment操作中的comment参数,或(2)推选图片时的rating参数,来执行任意SQL指令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20050609 Invision Gallery Vulnerabilities
(UNKNOWN)  BID  13907

- 漏洞信息

Invision Gallery SQL注入漏洞
高危 SQL注入
2005-06-09 00:00:00 2005-10-20 00:00:00
        Invision Gallery 1.3.1之前的版本中存在多个SQL注入漏洞,远程攻击者可借助:(1)editcomment操作中的comment参数,或(2)推选图片时的rating参数,来执行任意SQL指令。

- 公告与补丁


- 漏洞信息

Invision Gallery editcomment Command comment Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-06-09 Unknow
2005-06-09 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Invision Power Services Invision Gallery SQL Injection Vulnerability
Input Validation Error 13907
Yes No
2005-06-09 12:00:00 2009-07-12 02:56:00
Discovery is credited to James Bercegay of the GulfTech Security Research Team.

- 受影响的程序版本

Invision Power Services Invision Gallery 1.3
Invision Power Services Invision Gallery 1.0.1
Invision Power Services Invision Gallery 1.3.1

- 不受影响的程序版本

Invision Power Services Invision Gallery 1.3.1

- 漏洞讨论

Invision Gallery is affected by an SQL injection vulnerability.

This issue is due to a failure in the application to properly sanitize user-supplied input to the 'index.php' script before using it in an SQL query.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

Invision Gallery 1.3.0 and prior are vulnerable.

- 漏洞利用

An exploit is not required.

The following proof of concept is available:

- 解决方案

The vendor has released Invision Gallery 1.3.1 to address this issue. Please contact the vendor for more information.

- 相关参考