CVE-2005-1917
CVSS2.1
发布时间 :2005-07-05 00:00:00
修订时间 :2008-09-05 16:50:25
NMCOS    

[原文]kpopper 1.0 and earlier allows local users to create and overwrite arbitrary files via a symlink attack on the .popper-new temporary file.


[CNNVD]Kpopper symlink 文件覆盖漏洞(CNNVD-200507-017)

        kpopper是一款开源软件,提供类似于winpop的功能。
        kpopper 1.0及之前版本存在文件覆盖漏洞。
        本地用户通过符号链接.popper-new临时文件,可以创建和覆盖任意文件。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1917
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1917
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-017
(官方数据源) CNNVD

- 其它链接及资源

http://www.zataz.net/adviso/kpopper-06152005.txt
(VENDOR_ADVISORY)  MISC  http://www.zataz.net/adviso/kpopper-06152005.txt

- 漏洞信息

Kpopper symlink 文件覆盖漏洞
低危 设计错误
2005-07-05 00:00:00 2005-10-20 00:00:00
本地  
        kpopper是一款开源软件,提供类似于winpop的功能。
        kpopper 1.0及之前版本存在文件覆盖漏洞。
        本地用户通过符号链接.popper-new临时文件,可以创建和覆盖任意文件。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://kpopper.sourceforge.net/

- 漏洞信息

17725
Kpopper popper-send.sh Symlink Arbitrary File Manipulation
Local Access Required Race Condition

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-07-04 2005-06-13
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Popper Insecure Temporary File Creation Vulnerability
Design Error 14149
No Yes
2005-07-05 12:00:00 2009-07-12 04:06:00
Discovery is credited to zataz.

- 受影响的程序版本

Popper Popper 1.0
Popper Popper 0.93
Log4sh Log4sh 1.2.5
Log4sh Log4sh 1.2.4
Log4sh Log4sh 1.2.3
Log4sh Log4sh 1.2.6

- 不受影响的程序版本

Log4sh Log4sh 1.2.6

- 漏洞讨论

Popper creates temporary files in an insecure manner. An attacker with local access could potentially exploit this issue to overwrite files in the context of the application.

Exploitation would most likely result in loss of data or a denial of service if critical files are overwritten in the attack. There is also an unconfirmed potential for privilege escalation if the attacker can write custom data in the attack.

- 漏洞利用

There is no exploit required.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.


Log4sh Log4sh 1.2.3

Log4sh Log4sh 1.2.4

Log4sh Log4sh 1.2.5

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站