CVE-2005-1877
CVSS4.3
发布时间 :2005-06-06 00:00:00
修订时间 :2008-09-05 16:50:19
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in view_ticket.php in Lpanel 1.59 and earlier allows remote attackers to inject arbitrary web script or HTML and obtain sensitive information via the pid parameter.


[CNNVD]Lpanel 'view_ticket.php'脚本 跨站脚本攻击漏洞(CNNVD-200506-039)

        Lpanel 1.59 及早期版本的view_ticket.php脚本存在跨站脚本攻击(XSS)漏洞,远程攻击者可借助pid参数注入任意Web脚本或HTML,并获得敏感信息。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1877
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1877
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-039
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/13869
(VENDOR_ADVISORY)  BID  13869
http://secunia.com/advisories/15589/
(UNKNOWN)  SECUNIA  15589
http://lists.grok.org.uk/pipermail/full-disclosure/2005-June/034413.html
(VENDOR_ADVISORY)  FULLDISC  20050606 Lpanel.NET's Lpanel (all versions up to and including 1.59) is vulnerable to plain-text session credential leakage via script injection.

- 漏洞信息

Lpanel 'view_ticket.php'脚本 跨站脚本攻击漏洞
中危 跨站脚本
2005-06-06 00:00:00 2005-10-20 00:00:00
远程  
        Lpanel 1.59 及早期版本的view_ticket.php脚本存在跨站脚本攻击(XSS)漏洞,远程攻击者可借助pid参数注入任意Web脚本或HTML,并获得敏感信息。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        LPanel LPanel 1.59
        LPanel LPanel 1.597
        http://lpanel.net/members.php
        LPanel LPanel 1.593
        LPanel LPanel 1.597
        http://lpanel.net/members.php
        LPanel LPanel 1.594
        LPanel LPanel 1.597
        http://lpanel.net/members.php
        LPanel LPanel 1.596
        LPanel LPanel 1.597
        http://lpanel.net/members.php

- 漏洞信息

17132
Lpanel view_ticket.php pid Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Lpanel contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the user-submitted HTML or script via the pid parameter upon submission to the view_ticket.php script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-06-06 Unknow
2005-06-06 Unknow

- 解决方案

Upgrade to version 1.597 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

LPanel Multiple Input Validation Vulnerabilities
Input Validation Error 13869
Yes No
2005-06-06 12:00:00 2009-07-12 02:56:00
Discovery of these issues is credited to Zackarin Smitz.

- 受影响的程序版本

LPanel LPanel 1.596
LPanel LPanel 1.594
LPanel LPanel 1.593
LPanel LPanel 1.59
LPanel LPanel 1.597

- 不受影响的程序版本

LPanel LPanel 1.597

- 漏洞讨论

LPanel is prone to multiple input validation vulnerabilities, all of the vulnerabilities require authentication to be exploited. The following issues are reported:

The domain name value passed to the 'domain' parameter of the 'diagnose.php' script is not sufficient sanitized. This may allow an authenticated attacker to reset DNS values for target domains that are controlled by LPanel.

Input passed to the 'close', 'pid', and 'open' parameters of the 'view_ticket.php' script is not sufficiently sanitized. An authenticated attacker may leverage this issue to respond to arbitrary support tickets. Additionally, input passed to the 'pid' parameter may be used to launch HTML injection attacks.

The 'inv' URI parameter, passed to the 'viewreceipt.php' script is not properly sanitized. An authenticated attacker may leverage this issue to view arbitrary receipts.

The 'editdomain' URI parameter, passed to the 'domains.php' script is not properly sanitized. An authenticated attacker may leverage this issue to change DNS information for arbitrary LPanel accounts.

These issues are reported to exist in LPanel versions 1.59 and prior.

- 漏洞利用

No exploit is required.

- 解决方案

The vendor has addressed this issue in LPanel version 1.597:


LPanel LPanel 1.59

LPanel LPanel 1.593

LPanel LPanel 1.594

LPanel LPanel 1.596

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站