CVE-2005-1859
CVSS7.2
发布时间 :2005-07-12 00:00:00
修订时间 :2008-09-05 16:50:16
NMCOS    

[原文]Unknown vulnerability in arshell in the Array Service (arrayd) for SGI ProPack 3 with SP 5 and 6, and SGI ProPack 4, allows local users to execute arbitrary shells as root on other hosts in the cluster or array.


[CNNVD]SGI ProPack arshell 权限提升漏洞(CNNVD-200507-138)

        SGI ProPack是一款由SGI公司开发和维护的商业性质Unix操作系统。
        SGI ProPack 3 sp5/sp6 及SGI ProPack 4中Array Service软件包的arshell命令中存在未知的权限提升漏洞。
        本地用户可利用此漏洞,在配置的集群中其他主机上以root身份运行任意shell。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:sgi:propack:3.0:sp6
cpe:/a:sgi:propack:4.0SGI ProPack 4.0
cpe:/a:sgi:propack:3.0:sp5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1859
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1859
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-138
(官方数据源) CNNVD

- 其它链接及资源

http://securitytracker.com/id?1014454
(PATCH)  SECTRACK  1014454
ftp://patches.sgi.com/support/free/security/advisories/20050701-01-P.asc
(VENDOR_ADVISORY)  SGI  20050701-01-P

- 漏洞信息

SGI ProPack arshell 权限提升漏洞
高危 访问验证错误
2005-07-12 00:00:00 2005-10-20 00:00:00
远程  
        SGI ProPack是一款由SGI公司开发和维护的商业性质Unix操作系统。
        SGI ProPack 3 sp5/sp6 及SGI ProPack 4中Array Service软件包的arshell命令中存在未知的权限提升漏洞。
        本地用户可利用此漏洞,在配置的集群中其他主机上以root身份运行任意shell。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        ftp://patches.sgi.com/support/free/security/advisories/20050701-01-P.asc

- 漏洞信息

17831
SGI ProPack arrayd arshell Command Local Privilege Escalation
Local Access Required
Loss of Integrity Patch / RCS
Vendor Verified

- 漏洞描述

- 时间线

2005-07-01 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, SGI has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SGI ArrayD ARShell Remote Privilege Escalation Vulnerability
Access Validation Error 14218
Yes No
2005-07-12 12:00:00 2009-07-12 04:06:00
This vulnerability was disclosed by the vendor.

- 受影响的程序版本

SGI ProPack 4.0
SGI ProPack 3.0 SP6
SGI ProPack 3.0 SP5
SGI ProPack 3.0 SP4
SGI ProPack 3.0 SP3
SGI ProPack 3.0 SP2
SGI ProPack 3.0 SP1
SGI ProPack 3.0

- 不受影响的程序版本

SGI ProPack 3.0 SP4
SGI ProPack 3.0 SP3
SGI ProPack 3.0 SP2
SGI ProPack 3.0 SP1
SGI ProPack 3.0

- 漏洞讨论

SGI arshell is susceptible to a remote unspecified privilege escalation vulnerability.

In certain unspecified circumstances, users executing arshell may be able to execute commands on remote array computers with superuser privileges.

This vulnerability allows attackers to gain superuser privileges on any computer in an array or cluster.

Further details are not currently available. This BID will be updated as more information is disclosed.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

SGI has released an advisory, along with patches to address this issue.

For users of SGI ProPack 3 Service Pack 5, apply patch 10181.
For users of SGI ProPack 3 Service Pack 6, apply aatch 10185.
For users of SGI ProPack 4, apply patch 10182.

Patches may be obtained from http://support.sgi.com/.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站