CVE-2005-1857
CVSS7.5
发布时间 :2005-09-02 18:03:00
修订时间 :2011-03-07 21:23:00
NMCOS    

[原文]Format string vulnerability in simpleproxy before 3.4 allows remote malicious HTTP proxies to execute arbitrary code via format string specifiers in a reply.


[CNNVD]Simpleproxy reply 格式化字符串漏洞(CNNVD-200509-027)

        Simpleproxy是一款简单的代理服务器软件。
        simpleproxy 3.4以前的版本中存在格式化字符串漏洞。该漏洞允许远程恶意HTTP代理服务器可以借助于回复中的格式化字符串说明赋执行任意的代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:simpleproxy:simpleproxy:3.1
cpe:/a:simpleproxy:simpleproxy:3.0
cpe:/a:simpleproxy:simpleproxy:2.2b
cpe:/a:simpleproxy:simpleproxy:3.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1857
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1857
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200509-027
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/139421
(UNKNOWN)  CERT-VN  VU#139421
http://xforce.iss.net/xforce/xfdb/22016
(PATCH)  XF  simpleproxy-reply-format-string(22016)
http://www.securityfocus.com/bid/14666
(PATCH)  BID  14666
http://www.debian.org/security/2005/dsa-786
(VENDOR_ADVISORY)  DEBIAN  DSA-786
http://sourceforge.net/project/shownotes.php?group_id=604&release_id=351847
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?group_id=604&release_id=351847
http://secunia.com/advisories/16567/
(VENDOR_ADVISORY)  SECUNIA  16567

- 漏洞信息

Simpleproxy reply 格式化字符串漏洞
高危 格式化字符串
2005-09-02 00:00:00 2006-01-30 00:00:00
远程  
        Simpleproxy是一款简单的代理服务器软件。
        simpleproxy 3.4以前的版本中存在格式化字符串漏洞。该漏洞允许远程恶意HTTP代理服务器可以借助于回复中的格式化字符串说明赋执行任意的代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        Simpleproxy Simpleproxy 2.2 b
        Simpleproxy simpleproxy-3.4.tar.gz
        http://prdownloads.sourceforge.net/simpleproxy/simpleproxy-3.4.tar.gz?download
        Simpleproxy Simpleproxy 3.0
        Simpleproxy simpleproxy-3.4.tar.gz
        http://prdownloads.sourceforge.net/simpleproxy/simpleproxy-3.4.tar.gz?download
        Simpleproxy Simpleproxy 3.1
        Simpleproxy simpleproxy-3.4.tar.gz
        http://prdownloads.sourceforge.net/simpleproxy/simpleproxy-3.4.tar.gz?download
        Simpleproxy Simpleproxy 3.2
        Simpleproxy simpleproxy-3.4.tar.gz
        http://prdownloads.sourceforge.net/simpleproxy/simpleproxy-3.4.tar.gz?download

- 漏洞信息

19008
Simpleproxy HTTP Proxy Reply Remote Format String
Remote / Network Access, Local / Remote, Context Dependent Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-08-26 Unknow
2005-08-29 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Simpleproxy Remote Syslog() Format String Vulnerability
Input Validation Error 14666
Yes No
2005-08-26 12:00:00 2009-07-12 05:06:00
Ulf Harnhammar from the Debian Security Audit Project discovered this vulnerability.

- 受影响的程序版本

Simpleproxy Simpleproxy 3.2
Simpleproxy Simpleproxy 3.1
Simpleproxy Simpleproxy 3.0
Simpleproxy Simpleproxy 2.2 b
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Simpleproxy Simpleproxy 3.4

- 不受影响的程序版本

Simpleproxy Simpleproxy 3.4

- 漏洞讨论

It is reported that simpleproxy contains a format string vulnerability. This issue is due to a failure of the applications to properly sanitize user-supplied input before using it as the format specifier in a formatted printing function.

Successful exploitation of this issue will allow an attacker to execute arbitrary code on the affected computer with the privileges of the affected package. This application may be run as the superuser in order to proxy privileged TCP ports.

Versions of simpleproxy prior to 3.4 are reported susceptible to this vulnerability.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

The vendor has released version 3.4 of simpleproxy to address this issue.

Debian GNU/Linux has released advisory DSA 786-1, along with fixes to address this issue. Please see the referenced advisory for further information.


Simpleproxy Simpleproxy 2.2 b

Simpleproxy Simpleproxy 3.0

Simpleproxy Simpleproxy 3.1

Simpleproxy Simpleproxy 3.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站