CVE-2005-1841
CVSS2.1
发布时间 :2005-07-07 00:00:00
修订时间 :2008-09-05 16:50:14
NMCOS    

[原文]The control for Adobe Reader 5.0.9 and 5.0.10 on Linux, Solaris, HP-UX, and AIX creates temporary files with the permissions as specified in a user's umask, which could allow local users to read PDF documents of that user if the umask allows it.


[CNNVD]Adobe Reader 临时文件 信息泄露漏洞(CNNVD-200507-075)

        Adobe Reader是非常流行的PDF文件阅读器。
        Adobe Reader for Unix的5.0.9及5.0.10版本中存在信息泄漏漏洞。
        在使用Adobe Reader打开PDF文件时,会在临时文件夹中随即生成临时文件,临时文件的权限是根据用户的umask产生,本地攻击者利用这个漏洞可能浏览其他用户的PDF文件。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:adobe:acrobat_reader:5.0.9Adobe Acrobat Reader 5.0.9
cpe:/a:adobe:acrobat_reader:5.0.10Adobe Acrobat Reader 5.0.10

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1841
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1841
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200507-075
(官方数据源) CNNVD

- 其它链接及资源

http://www.adobe.com/support/techdocs/329121.html
(VENDOR_ADVISORY)  CONFIRM  http://www.adobe.com/support/techdocs/329121.html
http://secunia.com/secunia_research/2005-6/advisory/
(VENDOR_ADVISORY)  MISC  http://secunia.com/secunia_research/2005-6/advisory/
http://secunia.com/advisories/14457
(VENDOR_ADVISORY)  SECUNIA  14457
http://www.redhat.com/support/errata/RHSA-2005-575.html
(UNKNOWN)  REDHAT  RHSA-2005:575

- 漏洞信息

Adobe Reader 临时文件 信息泄露漏洞
低危 设计错误
2005-07-07 00:00:00 2005-10-20 00:00:00
本地  
        Adobe Reader是非常流行的PDF文件阅读器。
        Adobe Reader for Unix的5.0.9及5.0.10版本中存在信息泄漏漏洞。
        在使用Adobe Reader打开PDF文件时,会在临时文件夹中随即生成临时文件,临时文件的权限是根据用户的umask产生,本地攻击者利用这个漏洞可能浏览其他用户的PDF文件。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://get.adobe.com/reader/otherversions/

- 漏洞信息

17615
Adobe Reader for Linux Temp File Permission Weakness Arbitrary Document Disclosure
Local Access Required Information Disclosure
Loss of Confidentiality Upgrade
Exploit Public RBS Confirmed, Vendor Verified, Coordinated Disclosure

- 漏洞描述

Adobe Reader for Linux contains a flaw that may lead to an unauthorized information disclosure.  The issue is triggered when opening documents as temporary copies are created insecurely, which will disclose document contents to a local attacker.

- 时间线

2005-06-30 2005-05-11
2005-06-29 2005-06-29

- 解决方案

Upgrade to version 7.0 for Linux or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Adobe Reader For Unix Local File Disclosure Vulnerability
Design Error 14165
No Yes
2005-07-06 12:00:00 2009-07-12 04:06:00
Discovery is credited to Carsten Eiram.

- 受影响的程序版本

RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Desktop 4.0
RedHat Desktop 3.0
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
Adobe Acrobat Reader (UNIX) 5.0.10
+ Gentoo Linux
Adobe Acrobat Reader (UNIX) 5.0.9
+ Gentoo Linux
+ S.u.S.E. Linux 8.1
+ S.u.S.E. Linux 8.0 i386
+ S.u.S.E. Linux 8.0
+ S.u.S.E. Linux Connectivity Server
+ S.u.S.E. Linux Database Server 0
+ S.u.S.E. Linux Desktop 1.0
+ S.u.S.E. Linux Enterprise Server 9
+ S.u.S.E. Linux Personal 9.2
+ S.u.S.E. Linux Personal 9.1
+ S.u.S.E. Linux Personal 9.0 x86_64
+ S.u.S.E. Linux Personal 9.0
+ S.u.S.E. Linux Personal 8.2
+ SuSE SUSE Linux Enterprise Server 8
+ SuSE SUSE Linux Enterprise Server 7
Adobe Acrobat Reader (UNIX) 7.0
Adobe Acrobat Reader (UNIX) 5.0.11

- 不受影响的程序版本

Adobe Acrobat Reader (UNIX) 7.0
Adobe Acrobat Reader (UNIX) 5.0.11

- 漏洞讨论

Adobe Reader for Unix is affected by a local file disclosure vulnerability.

An attacker may gain access to temporary files created by the application and subsequently disclose a victim user's PDF files.

Adobe Reader 5.0.9 and 5.0.10 are vulnerable to this issue.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has released Adobe Reader 7.0 as an upgrade for Adobe Reader 5.0.9 or 5.0.10 on Linux or Solaris. Adobe Reader 5.0.11 is available as an upgrade for 5.0.9 or 5.0.10 on IBM-AIX or HP-UX.

Red Hat has released advisory RHSA-2005:575-11 to address this issue. Please see the referenced advisory for more information.


Adobe Acrobat Reader (UNIX) 5.0.10

Adobe Acrobat Reader (UNIX) 5.0.9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站