CVE-2005-1814
CVSS7.5
发布时间 :2005-06-01 00:00:00
修订时间 :2016-10-17 23:22:39
NMCOS    

[原文]Stack-based buffer overflow in PicoWebServer 1.0 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a long URL.


[CNNVD]PicoWebServer 远程栈溢出漏洞(CNNVD-200506-013)

        PicoWebServer是运行Windows CE操作系统的PocketPC使用的免费Web Server。
        PicoWebServer在处理超长的URL时存在漏洞,远程攻击者可以导致Web Server崩溃。
        如果攻击者能够提供足够大的URL的话,就可以触发这个溢出,导致应用程序崩溃。成功的攻击允许远程攻击者完全控制设备。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1814
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1814
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-013
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111746551802380&w=2
(UNKNOWN)  BUGTRAQ  20050528 PicoWebServer Remote Unicode Stack Overflow
http://www.securityfocus.com/bid/13807
(UNKNOWN)  BID  13807

- 漏洞信息

PicoWebServer 远程栈溢出漏洞
高危 缓冲区溢出
2005-06-01 00:00:00 2005-10-20 00:00:00
远程  
        PicoWebServer是运行Windows CE操作系统的PocketPC使用的免费Web Server。
        PicoWebServer在处理超长的URL时存在漏洞,远程攻击者可以导致Web Server崩溃。
        如果攻击者能够提供足够大的URL的话,就可以触发这个溢出,导致应用程序崩溃。成功的攻击允许远程攻击者完全控制设备。
        

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.newmad.se/

- 漏洞信息

16910
PicoWebServer Unicode HTTP Request Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

A remote overflow exists in PicoWebServer. The application fails to perform proper bounds checking resulting in a buffer overflow. With an overly long HTTP GET request, a remote attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-05-28 2005-05-23
2005-05-28 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Newmad Technologies PicoWebServer Remote Buffer Overflow Vulnerability
Boundary Condition Error 13807
Yes No
2005-05-28 12:00:00 2009-07-12 02:56:00
Discovery is credited to Dennis Elser <dennis@backtrace.de>.

- 受影响的程序版本

Newmad Technologies PicoWebServer 1.0

- 漏洞讨论

PicoWebServer is affected by a remote buffer overflow vulnerability.

The vulnerability presents itself when the application handles long HTTP GET requests. A successful attack can result in a denial of service condition or arbitrary code execution.

PicoWebServer 1.0 is affected by this issue.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站