CVE-2005-1810
CVSS7.5
发布时间 :2005-06-01 00:00:00
修订时间 :2016-10-17 23:22:38
NMCOS    

[原文]SQL injection vulnerability in template-functions-category.php in WordPress 1.5.1 allows remote attackers to execute arbitrary SQL commands via the $cat_ID variable, as demonstrated using the cat parameter to index.php.


[CNNVD]WordPress 'template-functions-category.php'脚本 SQL注入漏洞(CNNVD-200506-014)

        WordPress 1.5.1中的template-functions-category.php脚本存在SQL注入漏洞,远程攻击者可借助$cat_ID变量执行任意SQL指令,比如使用提交到index.php脚本的cat参数。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1810
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1810
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-014
(官方数据源) CNNVD

- 其它链接及资源

http://bugs.gentoo.org/show_bug.cgi?id=94512
(UNKNOWN)  CONFIRM  http://bugs.gentoo.org/show_bug.cgi?id=94512
http://marc.info/?l=bugtraq&m=111817436619067&w=2
(UNKNOWN)  BUGTRAQ  20050607 SQL Injection Exploit for WordPress <= 1.5.1.1
http://security.gentoo.org/glsa/glsa-200506-04.xml
(UNKNOWN)  GENTOO  GLSA-200506-04
http://wordpress.org/development/2005/05/security-update/
(VENDOR_ADVISORY)  CONFIRM  http://wordpress.org/development/2005/05/security-update/
http://www.securityfocus.com/bid/13809
(UNKNOWN)  BID  13809

- 漏洞信息

WordPress 'template-functions-category.php'脚本 SQL注入漏洞
高危 SQL注入
2005-06-01 00:00:00 2005-10-20 00:00:00
远程  
        WordPress 1.5.1中的template-functions-category.php脚本存在SQL注入漏洞,远程攻击者可借助$cat_ID变量执行任意SQL指令,比如使用提交到index.php脚本的cat参数。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        WordPress WordPress 1.5
        WordPress WordPress Latest Release Download
        http://wordpress.org/latest.tar.gz
        WordPress WordPress 1.5.1
        WordPress WordPress Latest Release Download
        http://wordpress.org/latest.tar.gz

- 漏洞信息

16905
WordPress template-functions-category.php cat_ID SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Exploit Unknown Vendor Verified

- 漏洞描述

WordPress contains a flaw that may allow a remote attacker to inject arbitrary SQL queries. The issue is due to the 'cat_ID' variable in the 'template-functions-category.php' script not being properly sanitized and may allow a remote attacker to inject or manipulate SQL queries.

- 时间线

2005-05-27 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.5.1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Wordpress Cat_ID Parameter SQL Injection Vulnerability
Input Validation Error 13809
Yes No
2005-05-30 12:00:00 2009-07-12 02:56:00
The individual or individuals responsible for the discovery of this issue are currently unknown; the vendor disclosed this issue.

- 受影响的程序版本

WordPress WordPress 1.5.1
WordPress WordPress 1.5
Gentoo Linux
WordPress WordPress 1.5.1 .2

- 不受影响的程序版本

WordPress WordPress 1.5.1 .2

- 漏洞讨论

Wordpress is prone to an SQL injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

- 漏洞利用

No exploit is required.

"Alberto Trivero" &lt;trivero@jumpy.it&gt; has supplied the wordpress-sql-inj.pl exploit.

1dt.w0lf has provided the wordpress1511newadmin.pl exploit.

- 解决方案

The vendor has addressed this issue in Wordpress version 1.5.1.2:

Gentoo has released advisory GLSA 200506-04 to address this issue. Please see the referenced advisory for more information. Gentoo users may update their computers by carrying out the following commands:

emerge --sync
emerge --ask --oneshot --verbose ">=www-apps/wordpress-1.5.1.2"


WordPress WordPress 1.5

WordPress WordPress 1.5.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站