CVE-2005-1807
CVSS5.0
发布时间 :2005-05-28 00:00:00
修订时间 :2011-03-07 21:22:54
NMCOS    

[原文]The Data function in class.smtp.php in PHPMailer 1.7.2 and earlier allows remote attackers to cause a denial of service (infinite loop leading to memory and CPU consumption) via a long header field.


[CNNVD]PHPMailer Data()调用远程拒绝服务漏洞(CNNVD-200505-1225)

        PHPMailer是一款PHP语言的全功能电子邮件传输程序库。
        PHPMailer实现上存在漏洞,远程攻击者可能通过畸形的邮件导致服务器崩溃。
        PHPMailer对邮件头的From字段处理存在问题,攻击者可以通过超长的字段值使服务器进程进入无限循环消耗大量资源从而导致崩溃。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1807
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1807
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-1225
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2007/2242
(UNKNOWN)  VUPEN  ADV-2007-2242
http://www.vupen.com/english/advisories/2006/0448
(UNKNOWN)  VUPEN  ADV-2006-0448
http://www.cybsec.com/vuln/PHPMailer-DOS.pdf
(VENDOR_ADVISORY)  MISC  http://www.cybsec.com/vuln/PHPMailer-DOS.pdf
http://securitytracker.com/id?1014069
(VENDOR_ADVISORY)  SECTRACK  1014069
http://www.securityfocus.com/bid/13805
(UNKNOWN)  BID  13805
http://sourceforge.net/project/shownotes.php?release_id=341210&group_id=26031
(UNKNOWN)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=341210&group_id=26031
http://secunia.com/advisories/25726
(UNKNOWN)  SECUNIA  25726
http://secunia.com/advisories/18732
(UNKNOWN)  SECUNIA  18732
http://secunia.com/advisories/15543
(UNKNOWN)  SECUNIA  15543

- 漏洞信息

PHPMailer Data()调用远程拒绝服务漏洞
中危 其他
2005-05-28 00:00:00 2005-10-20 00:00:00
远程  
        PHPMailer是一款PHP语言的全功能电子邮件传输程序库。
        PHPMailer实现上存在漏洞,远程攻击者可能通过畸形的邮件导致服务器崩溃。
        PHPMailer对邮件头的From字段处理存在问题,攻击者可以通过超长的字段值使服务器进程进入无限循环消耗大量资源从而导致崩溃。
        

- 公告与补丁

        目前厂商已经在1.7.3及以后版本的软件中修复这个安全问题,请到厂商的主页下载:
        http://phpmailer.sourceforge.net/

- 漏洞信息

16935
PHPMailer Header Processing Data() Function DoS
Denial of Service
Loss of Availability
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-05-30 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHPMailer Data() Function Remote Denial of Service Vulnerability
Failure to Handle Exceptional Conditions 13805
Yes No
2005-05-28 12:00:00 2007-06-18 07:59:00
Discovery is credited to Mariano Nunez Di Croce from CYBSEC.

- 受影响的程序版本

Xoops Xoops 2.0.12 a
Xoops Xoops 2.0.12
Xoops Xoops 2.0.11
Xoops Xoops 2.0.10
Xoops Xoops 2.0.9 .3
Xoops Xoops 2.0.9 .2
Xoops Xoops 2.0.5 .2
Xoops Xoops 2.0.5 .1
Xoops Xoops 2.0.5
Xoops Xoops 2.0.3
Xoops Xoops 2.0.2
Xoops Xoops 2.0.1
Xoops Xoops 2.0
PHPMailer PHPMailer 1.7.2
PHPMailer PHPMailer 1.7.1
PHPMailer PHPMailer 1.7
PHP Link Directory PHPLD 2.0
IPplan IPplan 4.85
Xoops Xoops 2.2.1
PHPMailer PHPMailer 1.7.3
IPplan IPplan 4.86

- 不受影响的程序版本

Xoops Xoops 2.2.1
PHPMailer PHPMailer 1.7.3
IPplan IPplan 4.86

- 漏洞讨论

PHPMailer is affected by a remote denial-of-service vulnerability.

An attacker can send an email message with a malformed header field to initiate an infinite loop in the application. This eventually leads to a crash due to resource exhaustion.

PHPMailer 1.72 and prior versions are affected by this issue.

- 漏洞利用

An exploit is not required.

The following proof of concept is available:
From: AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA... x 998

- 解决方案

The vendor has addressed this issue in PHPMailer 1.7.3.

Xoops has released an update regarding this issue. Please see the referenced Xoops web page for more information.


IPplan IPplan 4.85

PHPMailer PHPMailer 1.7

PHPMailer PHPMailer 1.7.1

PHPMailer PHPMailer 1.7.2

Xoops Xoops 2.0

Xoops Xoops 2.0.1

Xoops Xoops 2.0.10

Xoops Xoops 2.0.11

Xoops Xoops 2.0.12

Xoops Xoops 2.0.12 a

Xoops Xoops 2.0.2

Xoops Xoops 2.0.3

Xoops Xoops 2.0.5

Xoops Xoops 2.0.5 .1

Xoops Xoops 2.0.5 .2

Xoops Xoops 2.0.9 .3

Xoops Xoops 2.0.9 .2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站