CVE-2005-1799
CVSS4.3
发布时间 :2005-05-31 00:00:00
修订时间 :2008-09-05 16:50:07
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in FreeStyle Wiki 3.5.7 and WikiLite (FSWikiLite) .10 allows remote attackers to inject arbitrary web script or HTML via unknown vectors.


[CNNVD]FreeStyle Wiki附件HTML注入漏洞(CNNVD-200505-1236)

        FreeStyle Wiki 3.5.7和WikiLite (FSWikiLite) .10存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过未知向量注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:freestyle:wiki:3.5.7
cpe:/a:freestyle:wikilite:.10

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1799
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1799
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-1236
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/15538
(VENDOR_ADVISORY)  SECUNIA  15538
http://www.securityfocus.com/bid/13824
(UNKNOWN)  BID  13824

- 漏洞信息

FreeStyle Wiki附件HTML注入漏洞
中危 跨站脚本
2005-05-31 00:00:00 2005-10-20 00:00:00
远程  
        FreeStyle Wiki 3.5.7和WikiLite (FSWikiLite) .10存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过未知向量注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        FreeStyle Wiki WikiLite 0.0.10
        FreeStyle Wiki fswiki_lite_0_0_11.zip
        http://prdownloads.sourceforge.jp/fswiki/14800/fswiki_lite_0_0_11.zip
        FreeStyle Wiki Wiki 3.5.7
        FreeStyle Wiki wiki3_5_8.zip
        http://prdownloads.sourceforge.jp/fswiki/14798/wiki3_5_8.zip

- 漏洞信息

16958
FreeStyle Wiki Upload Attachment Script Insertion

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-05-19 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

FreeStyle Wiki Attachment HTML Injection Vulnerability
Input Validation Error 13824
Yes No
2005-05-31 12:00:00 2009-07-12 02:56:00
The vendor announced this vulnerability.

- 受影响的程序版本

FreeStyle Wiki WikiLite 0.0.10
FreeStyle Wiki Wiki 3.5.7
FreeStyle Wiki WikiLite 0.0.11
FreeStyle Wiki Wiki 3.5.8

- 不受影响的程序版本

FreeStyle Wiki WikiLite 0.0.11
FreeStyle Wiki Wiki 3.5.8

- 漏洞讨论

FreeStyle Wiki and WikiLite are prone to an HTML injection vulnerability. This issue is due to a failure in the applications to properly sanitize user-supplied input before using it in dynamically generated content.

Attacker-supplied HTML and script code would be executed in the context of the affected Web site, potentially allowing for theft of cookie-based authentication credentials. An attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible.

This issue reportedly affects FreeStyle Wiki version 3.5.7 and WikiLite 0.0.10; earlier versions may also be affected.

- 漏洞利用

No exploit is required.

- 解决方案

The vendor has addressed this issue in FreeStyle Wiki version 3.5.8 and in WikiLite version 0.0.11:


FreeStyle Wiki WikiLite 0.0.10

FreeStyle Wiki Wiki 3.5.7

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站