发布时间 :2005-05-24 00:00:00
修订时间 :2016-10-17 23:22:02

[原文]templates.admin.users.user_form_processing in Blue Coat Reporter before 7.1.2 allows authenticated users to gain administrator privileges via an HTTP POST that sets volatile.user.administrator to true.

[CNNVD]Blue Coat Reporter远程权限升级漏洞(CNNVD-200505-1189)

        Blue Coat Reporter的7.1.2之前版本中的templates.admin.users.user_form_processing允许认证用户通过一个将volatile.user.administrator设置为真的HTTP POST来获取管理员权限。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20050524 Blue Coat Reporter multiple remote vulnerabilities
(UNKNOWN)  BID  13723
(UNKNOWN)  VUPEN  ADV-2005-0589

- 漏洞信息

Blue Coat Reporter远程权限升级漏洞
中危 访问验证错误
2005-05-24 00:00:00 2005-10-20 00:00:00
        Blue Coat Reporter的7.1.2之前版本中的templates.admin.users.user_form_processing允许认证用户通过一个将volatile.user.administrator设置为真的HTTP POST来获取管理员权限。

- 公告与补丁


- 漏洞信息

Blue Coat Reporter Admin Account Creation Privilege Escalation
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Blue Coat Reporter contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered when a regular user submits a POST request to create a new user with administrative privileges. This flaw may lead to a loss of integrity.

- 时间线

2005-05-20 2005-05-19
2005-05-20 Unknow

- 解决方案

Upgrade to version 7.1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Blue Coat Reporter Remote Privilege Escalation Vulnerability
Access Validation Error 13723
Yes No
2005-05-24 12:00:00 2009-07-12 02:56:00
"Oliver Karow" <> is credited with the discovery of this vulnerability.

- 受影响的程序版本

Blue Coat Systems Blue Coat Reporter 7.1.1 .1
Blue Coat Systems Blue Coat Reporter 7.0
Blue Coat Systems Blue Coat Reporter 7.1.2

- 不受影响的程序版本

Blue Coat Systems Blue Coat Reporter 7.1.2

- 漏洞讨论

Blue Coat Reporter is prone to a remote privilege escalation vulnerability. This issue is due to a failure in the application to properly authenticate a user prior to permitting access to administrator functions.

A remote authenticated user can manipulate the form for adding new users and create a new user with administrator access.

The vendor has addressed this issue in the upcoming version 7.1.2 of the application.

- 漏洞利用

No exploit is required.

The following proof of concept is available using the user account test:
POST /?dp+templates.admin.users.user_form_processing HTTP/1.0
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg,
application/, application/, application/msword,
application/x-shockwave-flash, */*
Accept-Language: de
Content-Type: application/x-www-form-urlencoded
Proxy-Connection: Keep-Alive
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Pragma: no-cache
Cookie: session_id=d9430f0d59eb43871e2c38ab84627232; authusername7=test;
Content-Length: 170


- 解决方案

The vendor has addressed this issue in the upcoming version 7.1.2 of the application.

- 相关参考