CVE-2005-1696
CVSS2.6
发布时间 :2005-05-24 00:00:00
修订时间 :2016-10-17 23:21:53
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in PostNuke 0.750 and 0.760RC3 allow remote attackers to inject arbitrary web script or HTML via the (1) skin or (2) paletteid parameter to demo.php in the Xanthia module, or (3) the serverName parameter to config.php in the Multisites (aka NS-Multisites) module.


[CNNVD]PostNuke 多个跨站脚本攻击(XSS)漏洞(CNNVD-200505-1192)

        PostNuke 0.750及0.760RC3中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可以通过传给Xanthia模块内demo.php的(1)skin或(2)paletteid参数,或者传给Multisites(又称NS-Multisites)模块内config.php的(3)serverName参数,来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:postnuke_software_foundation:postnuke:0.750
cpe:/a:postnuke_software_foundation:postnuke:0.760_rc3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1696
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1696
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-1192
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111670506926649&w=2
(UNKNOWN)  BUGTRAQ  20050521 [SECURITYREASON.COM] PostNuke XSS and Full path disclosure
http://news.postnuke.com/modules.php?op=modload&name=News&file=article&sid=2691
(VENDOR_ADVISORY)  CONFIRM  http://news.postnuke.com/modules.php?op=modload&name=News&file=article&sid=2691

- 漏洞信息

PostNuke 多个跨站脚本攻击(XSS)漏洞
低危 跨站脚本
2005-05-24 00:00:00 2006-04-07 00:00:00
远程  
        PostNuke 0.750及0.760RC3中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可以通过传给Xanthia模块内demo.php的(1)skin或(2)paletteid参数,或者传给Multisites(又称NS-Multisites)模块内config.php的(3)serverName参数,来注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

16790
PostNuke Xanthia Module demo.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PostNuke contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "skin" and "paletteid" variables upon submission to the "demo.php" script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-05-21 Unknow
2005-05-21 Unknow

- 解决方案

Upgrade to version 0.750b or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站