CVE-2005-1681
CVSS7.5
发布时间 :2005-05-20 00:00:00
修订时间 :2016-10-17 23:21:37
NMCO    

[原文]PHP remote file inclusion vulnerability in common.php in phpATM 1.21, and possibly earlier versions, allows remote attackers to execute arbitrary PHP code via a URL in the include_location parameter to index.php.


[CNNVD]phpATM PHP远程文件包含漏洞(CNNVD-200505-1141)

        phpATM 1.21和可能的更早版本中的common.php中存在PHP远程文件包含漏洞,远程攻击者可以通过传给index.php的include_location参数中的URL,执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:bugada_andrea:php_advanced_transfer_manager:1.21
cpe:/a:bugada_andrea:php_advanced_transfer_manager:1.20

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1681
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1681
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-1141
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111653168810937&w=2
(UNKNOWN)  BUGTRAQ  20050519 phpATM arbitrary PHP code inclusion
http://securitytracker.com/id?1014008
(UNKNOWN)  SECTRACK  1014008

- 漏洞信息

phpATM PHP远程文件包含漏洞
高危 未知
2005-05-20 00:00:00 2006-09-07 00:00:00
远程  
        phpATM 1.21和可能的更早版本中的common.php中存在PHP远程文件包含漏洞,远程攻击者可以通过传给index.php的include_location参数中的URL,执行任意PHP代码。

- 公告与补丁

        暂无数据

- 漏洞信息

16692
PHP Advanced Transfer Manager (phpATM) index.php include_location Function Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

phpATM contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to index.php not properly sanitizing user input supplied to the include_location variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2005-05-19 Unknow
2005-05-19 Unknow

- 解决方案

Upgrade to version 1.2.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站