CVE-2005-1636
CVSS4.6
发布时间 :2005-05-17 00:00:00
修订时间 :2016-10-17 23:21:29
NMCOS    

[原文]mysql_install_db in MySQL 4.1.x before 4.1.12 and 5.x up to 5.0.4 creates the mysql_install_db.X file with a predictable filename and insecure permissions, which allows local users to execute arbitrary SQL commands by modifying the file's contents.


[CNNVD]MySQL mysql_install_db以不安全方式创建临时文件漏洞(CNNVD-200505-1086)

        MySQL是一款使用非常广泛的开放源代码关系数据库系统,拥有各种平台的运行版本。
        MySQL的安装脚本在创建临时文件时存在问题,本地攻击者可能利用此漏洞提升自己的权限。
        MySQL中的漏洞可能允许本地用户非授权访问数据库或获得权限提升,起因是以不安全的方式创建临时文件。这个漏洞影响mysql_install_db脚本。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mysql:mysql:4.0.1MySQL MySQL 4.0.1
cpe:/a:mysql:mysql:4.0.0MySQL MySQL 4.0.0
cpe:/a:mysql:mysql:4.0.3MySQL MySQL 4.0.3
cpe:/a:mysql:mysql:4.0.2MySQL MySQL 4.0.2
cpe:/a:mysql:mysql:4.0.11MySQL MySQL 4.0.11
cpe:/a:mysql:mysql:4.0.10MySQL MySQL 4.0.10
cpe:/a:mysql:mysql:4.0.7:gammaMySQL MySQL 4.0.7 gamma
cpe:/a:mysql:mysql:5.0.4MySQL MySQL 5.0.4
cpe:/a:mysql:mysql:5.0.3MySQL MySQL 5.0.3
cpe:/a:mysql:mysql:5.0.0:alphaMySQL MySQL 5.0.0 alpha
cpe:/a:mysql:mysql:5.0.2MySQL MySQL 5.0.2
cpe:/a:mysql:mysql:5.0.1MySQL MySQL 5.0.1
cpe:/a:mysql:mysql:5.0.0.0MySQL MySQL 5.0.0.0
cpe:/a:mysql:mysql:4.0.9:gammaMySQL MySQL 4.0.9 gamma
cpe:/a:mysql:mysql:4.0.11:gammaMySQL MySQL 4.0.11 gamma
cpe:/a:mysql:mysql:4.0.8:gammaMySQL MySQL 4.0.8 gamma
cpe:/a:mysql:mysql:4.0.9MySQL MySQL 4.0.9
cpe:/a:mysql:mysql:4.0.8MySQL MySQL 4.0.8
cpe:/a:mysql:mysql:4.0.5MySQL MySQL 4.0.5
cpe:/a:mysql:mysql:4.0.4MySQL MySQL 4.0.4
cpe:/a:mysql:mysql:4.0.5aMySQL MySQL 4.0.5a
cpe:/a:mysql:mysql:4.0.7MySQL MySQL 4.0.7
cpe:/a:mysql:mysql:4.0.6MySQL MySQL 4.0.6

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:9504mysql_install_db in MySQL 4.1.x before 4.1.12 and 5.x up to 5.0.4 creates the mysql_install_db.X file with a predictable filename and insecu...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1636
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1636
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-1086
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=full-disclosure&m=111632686805498&w=2
(UNKNOWN)  FULLDISC  20050517 MySQL < 4.0.12 && MySQL <= 5.0.4 : Insecure tmp
http://www.mandriva.com/security/advisories?name=MDKSA-2006:045
(UNKNOWN)  MANDRIVA  MDKSA-2006:045
http://www.redhat.com/support/errata/RHSA-2005-685.html
(UNKNOWN)  REDHAT  RHSA-2005:685
http://www.securityfocus.com/bid/13660
(UNKNOWN)  BID  13660
http://www.zataz.net/adviso/mysql-05172005.txt
(UNKNOWN)  MISC  http://www.zataz.net/adviso/mysql-05172005.txt
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=158688
(UNKNOWN)  CONFIRM  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=158688

- 漏洞信息

MySQL mysql_install_db以不安全方式创建临时文件漏洞
中危 设计错误
2005-05-17 00:00:00 2006-03-28 00:00:00
本地  
        MySQL是一款使用非常广泛的开放源代码关系数据库系统,拥有各种平台的运行版本。
        MySQL的安装脚本在创建临时文件时存在问题,本地攻击者可能利用此漏洞提升自己的权限。
        MySQL中的漏洞可能允许本地用户非授权访问数据库或获得权限提升,起因是以不安全的方式创建临时文件。这个漏洞影响mysql_install_db脚本。
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载4.0.12版本:
        http://www.mysql.com/

- 漏洞信息

16689
MySQL mysql_install_db Symlink Arbitrary File Overwrite
Local Access Required Race Condition
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-05-17 2005-05-07
2005-05-17 Unknow

- 解决方案

Upgrade to version 4.1.12 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

MySQL mysql_install_db Insecure Temporary File Creation Vulnerability
Design Error 13660
No Yes
2005-05-17 12:00:00 2006-12-14 06:44:00
Discovery is credited to Eric Romang <eromang@zataz.net>.

- 受影响的程序版本

RedHat Enterprise Linux WS 4
RedHat Enterprise Linux ES 4
RedHat Desktop 4.0
Red Hat Fedora Core4
Red Hat Enterprise Linux AS 4
MySQL AB MySQL 5.0.4
MySQL AB MySQL 5.0.3
MySQL AB MySQL 5.0.2
MySQL AB MySQL 5.0.1
MySQL AB MySQL 5.0 .0-alpha
MySQL AB MySQL 5.0 .0-0
MySQL AB MySQL 4.0.11 -gamma
MySQL AB MySQL 4.0.11
+ Mandriva Linux Mandrake 9.1 ppc
+ Mandriva Linux Mandrake 9.1
MySQL AB MySQL 4.0.10
MySQL AB MySQL 4.0.9 -gamma
MySQL AB MySQL 4.0.9
MySQL AB MySQL 4.0.8 -gamma
MySQL AB MySQL 4.0.8
MySQL AB MySQL 4.0.7 -gamma
MySQL AB MySQL 4.0.7
MySQL AB MySQL 4.0.6
MySQL AB MySQL 4.0.5 a
MySQL AB MySQL 4.0.5
MySQL AB MySQL 4.0.4
MySQL AB MySQL 4.0.3
MySQL AB MySQL 4.0.2
MySQL AB MySQL 4.0.1
MySQL AB MySQL 4.0 .0
Mandriva Linux Mandrake 10.2 x86_64
Mandriva Linux Mandrake 10.2
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
MySQL AB MySQL 4.0.12

- 不受影响的程序版本

MySQL AB MySQL 4.0.12

- 漏洞讨论

MySQL is reportedly affected by a vulnerability that can allow local attackers to gain unauthorized access to the database or gain elevated privileges. This issue results from a design error due to the creation of temporary files in an insecure manner.

The vulnerability affects the 'mysql_install_db' script.

Due to the nature of the script, an attacker may create database accounts or gain elevated privileges.

MySQL versions prior to 4.0.12 and MySQL 5.x releases 5.0.4 and prior are reported to be affected.

- 漏洞利用

An exploit is not required.

- 解决方案


Reportedly, MySQL 4.0.12 is not affected by this issue.

Please see the referenced vendor advisories for more information.


MySQL AB MySQL 4.0.11

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站