CVE-2005-1621
CVSS5.0
发布时间 :2005-05-16 00:00:00
修订时间 :2016-10-17 23:21:23
NMCO    

[原文]Directory traversal vulnerability in the pnModFunc function in pnMod.php for PostNuke 0.750 through 0.760rc4 allows remote attackers to read arbitrary files via a .. (dot dot) in the func parameter to index.php.


[CNNVD]PostNuke 目录遍历漏洞(CNNVD-200505-1071)

        PostNuke 0.750至 0.760rc4版本的pnMod.php的pnModFunc函数存在目录遍历漏洞,远程攻击者可以通过一个传给index.php的func参数内的.. (点点)来读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:postnuke_software_foundation:postnuke:0.750
cpe:/a:postnuke_software_foundation:postnuke:0.760_rc2
cpe:/a:postnuke_software_foundation:postnuke:0.760_rc3
cpe:/a:postnuke_software_foundation:postnuke:0.760_rc4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1621
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1621
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-1071
(官方数据源) CNNVD

- 其它链接及资源

http://cvs.postnuke.com/viewcvs.cgi/Historic_PostNuke_Library/postnuke-devel/html/includes/pnMod.php.diff?r1=1.47&r2=1.48
(PATCH)  CONFIRM  http://cvs.postnuke.com/viewcvs.cgi/Historic_PostNuke_Library/postnuke-devel/html/includes/pnMod.php.diff?r1=1.47&r2=1.48
http://marc.info/?l=bugtraq&m=111627124301526&w=2
(UNKNOWN)  BUGTRAQ  20050516 Postnuke 0.750 - 0.760rc4 local file inclusion
http://news.postnuke.com/Article2690.html
(UNKNOWN)  CONFIRM  http://news.postnuke.com/Article2690.html
http://news.postnuke.com/modules.php?op=modload&name=News&file=article&sid=2691
(UNKNOWN)  CONFIRM  http://news.postnuke.com/modules.php?op=modload&name=News&file=article&sid=2691
http://www.vupen.com/english/advisories/2005/0553
(UNKNOWN)  VUPEN  ADV-2005-0553

- 漏洞信息

PostNuke 目录遍历漏洞
中危 路径遍历
2005-05-16 00:00:00 2006-04-07 00:00:00
远程  
        PostNuke 0.750至 0.760rc4版本的pnMod.php的pnModFunc函数存在目录遍历漏洞,远程攻击者可以通过一个传给index.php的func参数内的.. (点点)来读取任意文件。

- 公告与补丁

        暂无数据

- 漏洞信息

16617
PostNuke Blocks Module index.php func Parameter Traversal Arbitrary File Access
Remote / Network Access Input Manipulation
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-05-16 2005-05-03
2005-05-16 Unknow

- 解决方案

Upgrade to version 0.750b or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站