CVE-2005-1618
CVSS5.0
发布时间 :2005-05-16 00:00:00
修订时间 :2016-10-17 23:21:19
NMCOS    

[原文]The YMSGR URL handler in Yahoo! Messenger 5.x through 6.0 allows remote attackers to cause a denial of service (disconnect) via a room login or a room join request packet with a third : (colon) and an & (ampersand), which causes Messenger to send a corrupted packet to the server, which triggers a disconnect from the server.


[CNNVD]雅虎通URL处理程序远程拒绝服务漏洞(CNNVD-200505-1057)

        雅虎通是一款免费的即时通讯软件。
        雅虎通处理YMSGR: URL处理程序链接中参数的方式存在拒绝服务漏洞。
        攻击者可以通过特制的链接向Yahoo!的YMSG服务器发送特制报文。Yahoo!在接收这些报文时会立即断开当前会话。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:yahoo:messenger:6.0Yahoo Messenger 6.0
cpe:/a:yahoo:messenger:5.5Yahoo Messenger 5.5
cpe:/a:yahoo:messenger:5.6Yahoo Messenger 5.6

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1618
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1618
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-1057
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111601904204055&w=2
(UNKNOWN)  BUGTRAQ  20050513 Yahoo! Messenger URL Handler Remote DoS Vulnerability
http://www.securityfocus.com/bid/13626
(UNKNOWN)  BID  13626

- 漏洞信息

雅虎通URL处理程序远程拒绝服务漏洞
中危 其他
2005-05-16 00:00:00 2006-04-07 00:00:00
远程  
        雅虎通是一款免费的即时通讯软件。
        雅虎通处理YMSGR: URL处理程序链接中参数的方式存在拒绝服务漏洞。
        攻击者可以通过特制的链接向Yahoo!的YMSG服务器发送特制报文。Yahoo!在接收这些报文时会立即断开当前会话。
        

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://messenger.yahoo.com/

- 漏洞信息

16816
Yahoo! Messenger URL Handler Remote DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Public

- 漏洞描述

Yahoo! Messenger contains a flaw that may allow a remote denial of service. The issue is triggered due to the processing of arguments in the YMSGR: URL handler links. With a specially crafted request containing certain characters after the first or third colon, a remote attacker can causing the user to be disconnected from the current chat session resulting in a loss of availability.

- 时间线

2005-05-13 Unknow
2005-05-13 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Yahoo! Messenger URL Handler Remote Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 13626
Yes No
2005-05-13 12:00:00 2007-02-20 08:27:00
Torseq Tech. <bindshell@gmail.com> is credited with the discovery of this vulnerability.

- 受影响的程序版本

Yahoo! Messenger 6.0 .0.1921
Yahoo! Messenger 6.0 .0.1750
Yahoo! Messenger 6.0 .0.1643
Yahoo! Messenger 6.0
Yahoo! Messenger 5.6 .0.1358
Yahoo! Messenger 5.6 .0.1356
Yahoo! Messenger 5.6 .0.1355
Yahoo! Messenger 5.6 .0.1351
Yahoo! Messenger 5.6 .0.1347
Yahoo! Messenger 5.6
Yahoo! Messenger 5.5 .1249
Yahoo! Messenger 5.5
Yahoo! Messenger 5.0 .1232
Yahoo! Messenger 5.0 .1065
Yahoo! Messenger 5.0 .1046
Yahoo! Messenger 5.0
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows ME
- Microsoft Windows NT Workstation 4.0 SP6a
- Microsoft Windows NT Workstation 4.0 SP5
- Microsoft Windows NT Workstation 4.0 SP4
- Microsoft Windows NT Workstation 4.0 SP3
- Microsoft Windows NT Workstation 4.0 SP2
- Microsoft Windows NT Workstation 4.0 SP1
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows XP Home
Yahoo! Messenger 8.1.0.239
Yahoo! Messenger 8.1.0.209

- 不受影响的程序版本

Yahoo! Messenger 8.1.0.239
Yahoo! Messenger 8.1.0.209

- 漏洞讨论

Yahoo! Messenger is prone to a denial-of-service vulnerability because the application fails to handle exceptional conditions.

A remote user can cause Yahoo! Messenger to disconnect through malicious emails or web pages.

This issue is reported to affect Yahoo! Messenger versions 5.x to 6.0 Windows; other versions on other operating systems may also be affected.

- 漏洞利用

No exploit is required.

The following proofs of concept are available:

<a href="YMSGR:%63%68%61%74%3F:::%26%26%26%26">Click Here</a>
<a href="YMSGR:Chat?:::%26%26%26%26">Click Here</a>

- 解决方案

frisky chris <frisky.chris@yahoo.com> states that this issue does not affect version 8.1 of Yahoo! Messenger. Symantec has not confirmed this.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: mailto:vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站