CVE-2005-1597
CVSS4.3
发布时间 :2005-05-16 00:00:00
修订时间 :2016-10-17 23:21:09
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in (1) search.php and (2) topics.php for Invision Power Board (IPB) 2.0.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the highlite parameter.


[CNNVD]Invision Power Board Topics.PHP Highlite Parameter跨站脚本攻击漏洞(CNNVD-200505-1041)

        Invision Power Board (IPB) 2.0.3及更早版本中的 (1)search.php和(2)topics.php存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过highlite参数来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:invision_power_services:invision_board:1.0
cpe:/a:invision_power_services:invision_board:1.1.2
cpe:/a:invision_power_services:invision_board:1.3
cpe:/a:invision_power_services:invision_board:1.2
cpe:/a:invision_power_services:invision_power_board:2.0.3
cpe:/a:invision_power_services:invision_board:2.0_pdr3
cpe:/a:invision_power_services:invision_board:2.0_alpha_3
cpe:/a:invision_power_services:invision_board:1.0.1
cpe:/a:invision_power_services:invision_board:1.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1597
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1597
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-1041
(官方数据源) CNNVD

- 其它链接及资源

http://forums.invisionpower.com/index.php?showtopic=168016
(PATCH)  CONFIRM  http://forums.invisionpower.com/index.php?showtopic=168016
http://marc.info/?l=bugtraq&m=111539908705851&w=2
(UNKNOWN)  BUGTRAQ  20050506 Multiple Vulnerabilities In Invision Power Board
http://securitytracker.com/id?1013907
(UNKNOWN)  SECTRACK  1013907
http://www.gulftech.org/?node=research&article_id=00073-05052005
(PATCH)  MISC  http://www.gulftech.org/?node=research&article_id=00073-05052005
http://www.securityfocus.com/bid/13534
(UNKNOWN)  BID  13534
http://www.vupen.com/english/advisories/2005/0487
(UNKNOWN)  VUPEN  ADV-2005-0487
http://xforce.iss.net/xforce/xfdb/20445
(UNKNOWN)  XF  invision-powerboard-highlite-xss(20445)

- 漏洞信息

Invision Power Board Topics.PHP Highlite Parameter跨站脚本攻击漏洞
中危 跨站脚本
2005-05-16 00:00:00 2005-10-20 00:00:00
远程  
        Invision Power Board (IPB) 2.0.3及更早版本中的 (1)search.php和(2)topics.php存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过highlite参数来注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Invision Power Services Invision Board 1.0
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 1.0.1
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 1.1.1
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 1.1.2
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 1.2
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 1.3
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 1.3 Final
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 1.3
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 1.3.1 Final
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 2.0 PDR3
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 2.0
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 2.0 PF1
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 2.0 PF2
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 2.0 Alpha 3
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 2.0.1
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 2.0.2
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        Invision Power Services Invision Board 2.0.3
        Invision Power Services Invision Power Board 2.0.4
        http://www.invisionboard.com/act.ips/download
        

- 漏洞信息

16298
Invision Power Board topics.php highlite Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Invision Power Board contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'highlite' variable upon submission to the 'topics.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-05-05 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Invision Power Services, Inc. has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站