CVE-2005-1524
CVSS5.0
发布时间 :2005-06-22 00:00:00
修订时间 :2008-09-05 16:49:23
NMCOPS    

[原文]PHP file inclusion vulnerability in top_graph_header.php in Cacti 0.8.6d and possibly earlier versions allows remote attackers to execute arbitrary PHP code via the config[library_path] parameter.


[CNNVD]RaXnet Cacti 'top_graph_header.php'远程文件包含漏洞(CNNVD-200506-203)

        Cacti是一款轮循数据库(RRD)工具,可帮助从数据库信息创建图形,有多个Linux版本。
        Cacti的top_graph_header.php脚本中存在输入验证错误,允许攻击者包含远程站点的任意PHP代码,这可能导致以Web Server进程的权限执行任意命令。
        漏洞起因是脚本盲目信任用户提供的library_path变量。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:the_cacti_group:cacti:0.6.3
cpe:/a:the_cacti_group:cacti:0.5
cpe:/a:the_cacti_group:cacti:0.6.4
cpe:/a:the_cacti_group:cacti:0.6.5
cpe:/a:the_cacti_group:cacti:0.6.8a
cpe:/a:the_cacti_group:cacti:0.6.8
cpe:/a:the_cacti_group:cacti:0.8.6d
cpe:/a:the_cacti_group:cacti:0.8.2
cpe:/a:the_cacti_group:cacti:0.8.4
cpe:/a:the_cacti_group:cacti:0.8.2a
cpe:/a:the_cacti_group:cacti:0.6.1
cpe:/a:the_cacti_group:cacti:0.6.6
cpe:/a:the_cacti_group:cacti:0.8
cpe:/a:the_cacti_group:cacti:0.8.1
cpe:/a:the_cacti_group:cacti:0.6
cpe:/a:the_cacti_group:cacti:0.6.2
cpe:/a:the_cacti_group:cacti:0.8.5a
cpe:/a:the_cacti_group:cacti:0.8.3
cpe:/a:the_cacti_group:cacti:0.8.3a
cpe:/a:the_cacti_group:cacti:0.6.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1524
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1524
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-203
(官方数据源) CNNVD

- 其它链接及资源

http://www.idefense.com/application/poi/display?id=265&type=vulnerabilities&flashstatus=true
(VENDOR_ADVISORY)  IDEFENSE  20050622 Multiple Vendor Cacti Remote File Inclusion Vulnerability
http://www.gentoo.org/security/en/glsa/glsa-200506-20.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200506-20
http://www.cacti.net/release_notes_0_8_6e.php
(VENDOR_ADVISORY)  CONFIRM  http://www.cacti.net/release_notes_0_8_6e.php
http://xforce.iss.net/xforce/xfdb/21118
(UNKNOWN)  XF  cacti-topgraphheader-file-include(21118)
http://www.osvdb.org/17426
(UNKNOWN)  OSVDB  17426
http://www.debian.org/security/2005/dsa-764
(UNKNOWN)  DEBIAN  DSA-764
http://securitytracker.com/id?1014252
(UNKNOWN)  SECTRACK  1014252
http://secunia.com/advisories/16136
(UNKNOWN)  SECUNIA  16136
http://secunia.com/advisories/15931
(UNKNOWN)  SECUNIA  15931
http://secunia.com/advisories/15490
(UNKNOWN)  SECUNIA  15490
http://distro.conectiva.com/atualizacoes/index.php?id=a&anuncio=000978
(UNKNOWN)  CONECTIVA  CLSA-2005:978

- 漏洞信息

RaXnet Cacti 'top_graph_header.php'远程文件包含漏洞
中危 输入验证
2005-06-22 00:00:00 2006-08-28 00:00:00
远程  
        Cacti是一款轮循数据库(RRD)工具,可帮助从数据库信息创建图形,有多个Linux版本。
        Cacti的top_graph_header.php脚本中存在输入验证错误,允许攻击者包含远程站点的任意PHP代码,这可能导致以Web Server进程的权限执行任意命令。
        漏洞起因是脚本盲目信任用户提供的library_path变量。
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://security.gentoo.org/glsa/glsa-200506-20.xml
        http://www.cacti.net/downloads/cacti-0.8.6e.tar.gz
        http://www.cacti.net/downloads/cacti-0.8.6e.zip

- 漏洞信息 (F38833)

Debian Linux Security Advisory 764-1 (PacketStormID:F38833)
2005-07-22 00:00:00
Debian  security.debian.org
advisory,vulnerability
linux,debian
CVE-2005-1524,CVE-2005-1525,CVE-2005-1526,CVE-2005-2148,CVE-2005-2149
[点击下载]

Debian Security Advisory DSA 764-1 - Several vulnerabilities have been discovered in cacti, a round-robin database (RRD) tool that helps create graphs from database information.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 764-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
July 21st, 2005                         http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : cacti
Vulnerability  : several
Problem-Type   : remote
Debian-specific: no
CVE IDs        : CAN-2005-1524 CAN-2005-1525 CAN-2005-1526 CAN-2005-2148 CAN-2005-2149
Debian Bug     : 316590 315703

Several vulnerabilities have been discovered in cacti, a round-robin
database (RRD) tool that helps create graphs from database
information.  The Common Vulnerabilities and Exposures Project
identifies the following problems:

CAN-2005-1524

    Maciej Piotr Falkiewicz and an anonymous researcher discovered an
    input validation bug that allows an attacker to include arbitrary
    PHP code from remote sites which will allow the execution of
    arbitrary code on the server running cacti.

CAN-2005-1525

    Due to mising input validation cacti allows a remote attacker to
    insert arbitrary SQL statements.

CAN-2005-1526

    Maciej Piotr Falkiewicz discovered an input validation bug that
    allows an attacker to include arbitrary PHP code from remote sites
    which will allow the execution of arbitrary code on the server
    running cacti.

CAN-2005-2148

    Stefan Esser discovered that the update for the abovely mentioned
    vulnerabilities does not perform proper input validation to
    protect against common attacks.

CAN-2005-2149

    Stefan Esser discovered that the update for CAN-2005-1525 allows
    remote attackers to modify session information to gain privileges
    and disable the use of addslashes to protect against SQL
    injection.

For the old stable distribution (woody) these problems have been fixed in
version 0.6.7-2.5.

For the stable distribution (sarge) these problems have been fixed in
version 0.8.6c-7sarge2.

For the unstable distribution (sid) these problems have been fixed in
version 0.8.6e-1.

We recommend that you upgrade your cacti package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/c/cacti/cacti_0.6.7-2.5.dsc
      Size/MD5 checksum:      565 ca9cffd44ea6e8235005ce8e066fb88e
    http://security.debian.org/pool/updates/main/c/cacti/cacti_0.6.7-2.5.diff.gz
      Size/MD5 checksum:    25286 18aad674e7ef91dafb11af9a02c677d7
    http://security.debian.org/pool/updates/main/c/cacti/cacti_0.6.7.orig.tar.gz
      Size/MD5 checksum:   206608 b004ac1ca1dd18737f0fa685fe18737c

  Architecture independent components:

    http://security.debian.org/pool/updates/main/c/cacti/cacti_0.6.7-2.5_all.deb
      Size/MD5 checksum:   212418 ae47dc9aeb1820c5074fc39c5b6c84bc


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6c-7sarge2.dsc
      Size/MD5 checksum:      595 50f791f80662a02e982e82e4be7e59b5
    http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6c-7sarge2.diff.gz
      Size/MD5 checksum:    42575 a9959e2d720a6f7188c5713494b9eaaa
    http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6c.orig.tar.gz
      Size/MD5 checksum:  1046586 b4130300f671e773ebea3b8f715912c1

  Architecture independent components:

    http://security.debian.org/pool/updates/main/c/cacti/cacti_0.8.6c-7sarge2_all.deb
      Size/MD5 checksum:  1058544 2b5fe2ca0dc11a199c20f5bf7b3aa7ee


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFC3zhkW5ql+IAeqTIRAh4wAKCrgt02H1mCAVIRswU+tokjF4eVIgCfYuNE
V6ZewFZQrF1BzV4LVF1e3EI=
=GhQZ
-----END PGP SIGNATURE-----

    

- 漏洞信息

17426
Cacti top_graph_header.php config Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

- 时间线

2005-06-22 2005-05-12
Unknow 2005-06-22

- 解决方案

Upgrade to version 0.8.6e or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

RaXnet Cacti Graph_Image.PHP Remote Command Execution Variant Vulnerability
Input Validation Error 14129
Yes No
2005-07-01 12:00:00 2009-07-12 04:06:00
Stefan Esser of the Hardened PHP Project is credited with the discovery of this vulnerability.

- 受影响的程序版本

S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
Raxnet Cacti 0.8.6 e
Raxnet Cacti 0.8.6 d
Raxnet Cacti 0.8.6 c
Raxnet Cacti 0.8.6 b
Raxnet Cacti 0.8.6 a
Raxnet Cacti 0.8.6
Raxnet Cacti 0.8.5 a
Raxnet Cacti 0.8.5
Raxnet Cacti 0.8.4
Raxnet Cacti 0.8.3 a
Raxnet Cacti 0.8.3
Raxnet Cacti 0.8.2 a
Raxnet Cacti 0.8.2
Raxnet Cacti 0.8.1
Raxnet Cacti 0.8
Raxnet Cacti 0.6.8 a
Raxnet Cacti 0.6.8
Raxnet Cacti 0.6.7
+ Debian Linux 3.0
Raxnet Cacti 0.6.6
Raxnet Cacti 0.6.5
Raxnet Cacti 0.6.4
Raxnet Cacti 0.6.3
Raxnet Cacti 0.6.2
Raxnet Cacti 0.6.1
Raxnet Cacti 0.6
Raxnet Cacti 0.5
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 alpha
Debian Linux 3.1
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0
Conectiva Linux 10.0
Conectiva Linux 9.0
Raxnet Cacti 0.8.6 f

- 不受影响的程序版本

Raxnet Cacti 0.8.6 f

- 漏洞讨论

RaXnet Cacti is prone to a remote command execution vulnerability that manifests in the 'graph_image.php' script. The issue is due to a bug in the input filters that leads to a failure in the application to properly sanitize user-supplied input.

This issue can facilitate various attacks including unauthorized access to an affected computer.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has addressed this issue in Cacti version 0.8.6f:

Conectiva Linux advisory CLSA-2005:978 is available to address various issues affecting cacti. Please see the referenced advisory for more information.

SUSE has released advisory SUSE-SR:2005:017 to address various issues. Please see the referenced advisory for more information.

Debian GNU/Linux has released advisory DSA 764-1 to address various issues in Cacti. Please see the referenced advisory for further information.


Raxnet Cacti 0.5

Raxnet Cacti 0.6

Raxnet Cacti 0.6.1

Raxnet Cacti 0.6.2

Raxnet Cacti 0.6.3

Raxnet Cacti 0.6.4

Raxnet Cacti 0.6.5

Raxnet Cacti 0.6.6

Raxnet Cacti 0.6.7

Raxnet Cacti 0.6.8

Raxnet Cacti 0.6.8 a

Raxnet Cacti 0.8

Raxnet Cacti 0.8.1

Raxnet Cacti 0.8.2 a

Raxnet Cacti 0.8.2

Raxnet Cacti 0.8.3 a

Raxnet Cacti 0.8.3

Raxnet Cacti 0.8.4

Raxnet Cacti 0.8.5

Raxnet Cacti 0.8.5 a

Raxnet Cacti 0.8.6

Raxnet Cacti 0.8.6 b

Raxnet Cacti 0.8.6 d

Raxnet Cacti 0.8.6 c

Raxnet Cacti 0.8.6 a

Raxnet Cacti 0.8.6 e

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站