CVE-2005-1498
CVSS4.3
发布时间 :2005-05-11 00:00:00
修订时间 :2016-10-17 23:20:19
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in myBloggie 2.1.1 allow remote attackers to inject arbitrary web script or HTML via the (1) year parameter in viewmode.php, or the (2) cat_id, (3) month_no, or (4) post_id parameter in index.php, which are not properly sanitized before they are displayed in an error message. NOTE: issues 2, 3, and 4 may be due to a problem in associated products rather than myBloggie itself.


[CNNVD]MyBloggie多个输入验证漏洞(CNNVD-200505-949)

        myBloggie 2.1.1存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可通过(1)在viewmode.php的year参数,或在index.php中的(2)cat_id,(3)month_no或(4)post_id参数(这些参数在系统显示错误信息之前未经正确审查),注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:mywebland:mybloggie:2.1.2
cpe:/a:mywebland:mybloggie:2.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1498
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1498
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-949
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111531904608224&w=2
(UNKNOWN)  BUGTRAQ  20050505 Multiple vulnerabilities in myBloggie 2.1.1
http://www.securityfocus.com/bid/13507
(UNKNOWN)  BID  13507
http://xforce.iss.net/xforce/xfdb/20434
(UNKNOWN)  XF  mybloggie-viewmodephp-xss(20434)
http://xforce.iss.net/xforce/xfdb/20436
(UNKNOWN)  XF  mybloggie-script-injection(20436)

- 漏洞信息

MyBloggie多个输入验证漏洞
中危 跨站脚本
2005-05-11 00:00:00 2005-10-20 00:00:00
远程  
        myBloggie 2.1.1存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可通过(1)在viewmode.php的year参数,或在index.php中的(2)cat_id,(3)month_no或(4)post_id参数(这些参数在系统显示错误信息之前未经正确审查),注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

16360
myBloggie index.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

myBloggie contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'year', 'cat_id', 'month_no' or 'post_id' variables upon submission to the 'index.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-05-05 Unknow
2005-05-05 Unknow

- 解决方案

Upgrade to version 2.1.2 or higher, as it has been reported to fix this vulnerability. In addition, myWebland has released a patch for some older versions.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站