CVE-2005-1397
CVSS7.5
发布时间 :2005-05-03 00:00:00
修订时间 :2011-03-07 21:21:43
NMCOS    

[原文]SQL injection vulnerability in search.php for PHP-Calendar before 0.10.3 allows remote attackers to execute arbitrary SQL commands via unknown vectors.


[CNNVD]PHP-Calendar Search.PHP SQL注入漏洞(CNNVD-200505-865)

        PHP-Calendar 0.10.3之前版本的search.php存在SQL注入漏洞,远程攻击者可以通过未知向量执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php-calendar:php-calendar:0.9.1PHP-Calendar PHP-Calendar 0.9.1
cpe:/a:php-calendar:php-calendar:0.3PHP-Calendar PHP-Calendar 0.3
cpe:/a:php-calendar:php-calendar:0.2PHP-Calendar PHP-Calendar 0.2
cpe:/a:php-calendar:php-calendar:0.10PHP-Calendar PHP-Calendar 0.10
cpe:/a:php-calendar:php-calendar:0.9PHP-Calendar PHP-Calendar 0.9
cpe:/a:php-calendar:php-calendar:0.5PHP-Calendar PHP-Calendar 0.5
cpe:/a:php-calendar:php-calendar:0.1PHP-Calendar PHP-Calendar 0.1
cpe:/a:php-calendar:php-calendar:0.7PHP-Calendar PHP-Calendar 0.7
cpe:/a:php-calendar:php-calendar:0.6PHP-Calendar PHP-Calendar 0.6
cpe:/a:php-calendar:php-calendar:0.8PHP-Calendar PHP-Calendar 0.8
cpe:/a:php-calendar:php-calendar:0.4PHP-Calendar PHP-Calendar 0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1397
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1397
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-865
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/20297
(PATCH)  XF  php-calendar-searchphp-sql-injection(20297)
http://www.securityfocus.com/bid/13405
(PATCH)  BID  13405
http://secunia.com/advisories/15116
(PATCH)  SECUNIA  15116
http://www.vupen.com/english/advisories/2005/0418
(UNKNOWN)  VUPEN  ADV-2005-0418
http://www.osvdb.org/15866
(UNKNOWN)  OSVDB  15866
http://sourceforge.net/project/shownotes.php?release_id=323483
(UNKNOWN)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=323483

- 漏洞信息

PHP-Calendar Search.PHP SQL注入漏洞
高危 SQL注入
2005-05-03 00:00:00 2005-10-20 00:00:00
远程  
        PHP-Calendar 0.10.3之前版本的search.php存在SQL注入漏洞,远程攻击者可以通过未知向量执行任意SQL命令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        PHP-Calendar PHP-Calendar 0.1
        PHP-Calendar php-calendar-0.10.3.tar.gz
        http://prdownloads.sourceforge.net/php-calendar/php-calendar-0.10.3.ta r.gz?download
        PHP-Calendar PHP-Calendar 0.10
        PHP-Calendar php-calendar-0.10.3.tar.gz
        http://prdownloads.sourceforge.net/php-calendar/php-calendar-0.10.3.ta r.gz?download
        PHP-Calendar PHP-Calendar 0.2
        PHP-Calendar php-calendar-0.10.3.tar.gz
        http://prdownloads.sourceforge.net/php-calendar/php-calendar-0.10.3.ta r.gz?download
        PHP-Calendar PHP-Calendar 0.3
        PHP-Calendar php-calendar-0.10.3.tar.gz
        http://prdownloads.sourceforge.net/php-calendar/php-calendar-0.10.3.ta r.gz?download
        PHP-Calendar PHP-Calendar 0.4
        PHP-Calendar php-calendar-0.10.3.tar.gz
        http://prdownloads.sourceforge.net/php-calendar/php-calendar-0.10.3.ta r.gz?download
        PHP-Calendar PHP-Calendar 0.5
        PHP-Calendar php-calendar-0.10.3.tar.gz
        http://prdownloads.sourceforge.net/php-calendar/php-calendar-0.10.3.ta r.gz?download
        PHP-Calendar PHP-Calendar 0.6
        PHP-Calendar php-calendar-0.10.3.tar.gz
        http://prdownloads.sourceforge.net/php-calendar/php-calendar-0.10.3.ta r.gz?download
        PHP-Calendar PHP-Calendar 0.7
        PHP-Calendar php-calendar-0.10.3.tar.gz
        http://prdownloads.sourceforge.net/php-calendar/php-calendar-0.10.3.ta r.gz?download
        PHP-Calendar PHP-Calendar 0.8
        PHP-Calendar php-calendar-0.10.3.tar.gz
        http://prdownloads.sourceforge.net/php-calendar/php-calendar-0.10.3.ta r.gz?download
        PHP-Calendar PHP-Calendar 0.9
        PHP-Calendar php-calendar-0.10.3.tar.gz
        http://prdownloads.sourceforge.net/php-calendar/php-calendar-0.10.3.ta r.gz?download
        PHP-Calendar PHP-Calendar 0.9.1
        PHP-Calendar php-calendar-0.10.3.tar.gz
        http://prdownloads.sourceforge.net/php-calendar/php-calendar-0.10.3.ta r.gz?download
        

- 漏洞信息

15866
PHP-Calendar includes/search.php Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Exploit Unknown Vendor Verified

- 漏洞描述

PHP-Calendar contains a flaw that may allow a remote attacker to inject arbitrary SQL queries. The issue is due to improper validation of user-supplied input upon submission to the 'search.php' script and may allow a remote attacker to inject or manipulate SQL queries. No further details have been provided.

- 时间线

2005-04-26 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.10.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHP-Calendar Search.PHP SQL Injection Vulnerability
Input Validation Error 13405
Yes No
2005-04-27 12:00:00 2009-07-12 02:06:00
This vulnerability was announced by the vendor.

- 受影响的程序版本

PHP-Calendar PHP-Calendar 0.10
PHP-Calendar PHP-Calendar 0.9.1
PHP-Calendar PHP-Calendar 0.9
PHP-Calendar PHP-Calendar 0.8
PHP-Calendar PHP-Calendar 0.7
PHP-Calendar PHP-Calendar 0.6
PHP-Calendar PHP-Calendar 0.5
PHP-Calendar PHP-Calendar 0.4
PHP-Calendar PHP-Calendar 0.3
PHP-Calendar PHP-Calendar 0.2
PHP-Calendar PHP-Calendar 0.1
PHP-Calendar PHP-Calendar 0.10.3

- 不受影响的程序版本

PHP-Calendar PHP-Calendar 0.10.3

- 漏洞讨论

PHP-Calendar is prone to an SQL injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

The vendor has addressed this issue in PHP-Calendar 0.10.3; earlier versions are reported vulnerable.

- 漏洞利用

No exploit is required.

- 解决方案

The vendor has addressed this issue in PHP-Calendar version 0.10.3.


PHP-Calendar PHP-Calendar 0.1

PHP-Calendar PHP-Calendar 0.10

PHP-Calendar PHP-Calendar 0.2

PHP-Calendar PHP-Calendar 0.3

PHP-Calendar PHP-Calendar 0.4

PHP-Calendar PHP-Calendar 0.5

PHP-Calendar PHP-Calendar 0.6

PHP-Calendar PHP-Calendar 0.7

PHP-Calendar PHP-Calendar 0.8

PHP-Calendar PHP-Calendar 0.9

PHP-Calendar PHP-Calendar 0.9.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站