发布时间 :2005-05-03 00:00:00
修订时间 :2011-03-07 21:21:42

[原文]Buffer overflow in the add_port function in APSIS Pound 1.8.2 and earlier allows remote attackers to execute arbitrary code via a long Host HTTP header.

[CNNVD]APSIS Pound远程缓冲区溢出漏洞(CNNVD-200505-895)

        APSIS Pound 1.8.2及更早版本中的add_port函数存在缓冲区溢出,远程攻击者可以通过长的主机HTTP报头来执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  13436
(UNKNOWN)  XF  pound-addport-bo(20316)
(UNKNOWN)  VUPEN  ADV-2005-0437
(UNKNOWN)  MLIST  [pound_list] 20050426 remote buffer overflow in pound 1.8.2 + question abotu Host header

- 漏洞信息

APSIS Pound远程缓冲区溢出漏洞
高危 缓冲区溢出
2005-05-03 00:00:00 2006-09-25 00:00:00
        APSIS Pound 1.8.2及更早版本中的add_port函数存在缓冲区溢出,远程攻击者可以通过长的主机HTTP报头来执行任意代码。

- 公告与补丁

        APSIS Pound 1.8.2
        APSIS Pound-1.8.3.tgz

- 漏洞信息 (F42936)

Debian Linux Security Advisory 934-1 (PacketStormID:F42936)
2006-01-10 00:00:00

Debian Security Advisory DSA 934-1 - Two vulnerabilities have been discovered in Pound, a reverse proxy and load balancer for HTTP.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 934-1                                    Moritz Muehlenhoff
January 9, 2006               
- --------------------------------------------------------------------------

Package        : pound
Vulnerability  : several
Problem-Type   : remote
Debian-specific: no
CVE ID         : CVE-2005-1391 CVE-2005-3751
Debian Bug     : 307852

Two vulnerabilities have been discovered in Pound, a reverse proxy and
load balancer for HTTP. The Common Vulnerabilities and Exposures project
identifies the following problems:

   * CVE-2005-1391:
     Overly long HTTP Host: headers may trigger a buffer overflow in the
     add_port() function, which may lead to the execution of arbitrary

   * CVE-2005-3751:
     HTTP requests with conflicting Content-Length and Transfer-Encoding
     headers could lead to HTTP Request Smuggling Attack, which can be
     exploited to bypass packet filters or poison web caches.

The old stable distribution (woody) does not contain pound packages.

For the stable distribution (sarge) these problems have been fixed in
version 1.8.2-1sarge1

For the unstable distribution (sid) these problems have been fixed in
version 1.9.4-1

We recommend that you upgrade your pound package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:
      Size/MD5 checksum:      643 334d91f8800581281ab9c8bad5bbdbf4
      Size/MD5 checksum:    13242 9e404c899bfd5409610ed5f14345d341
      Size/MD5 checksum:   140455 c9b0793bb4d57be2270093d79b13c019

  Alpha architecture:
      Size/MD5 checksum:    73284 0458e20d63c3f5f5788afe7564a385da

  AMD64 architecture:
      Size/MD5 checksum:    68652 01ae48ac313a8e533f32eec2f6f7a62f

  ARM architecture:
      Size/MD5 checksum:    69072 73b7eb49a74c8a5ff6a8015cf9a0e45d

  Intel IA-32 architecture:
      Size/MD5 checksum:    68684 da43b8adaf115680c72d8f5dce9bc99f

  Intel IA-64 architecture:
      Size/MD5 checksum:    80756 ec6d043c70e50e8ba492ef6a73a4cc18

  HP Precision architecture:
      Size/MD5 checksum:    70288 22fa75150b2253640667714cf6197567

  Motorola 680x0 architecture:
      Size/MD5 checksum:    65138 1de5e7b4492a51900e13f9a0f5decd18

  Big endian MIPS architecture:
      Size/MD5 checksum:    68586 3eb28320dc9229ee8cc08d2967e8ee9b

  Little endian MIPS architecture:
      Size/MD5 checksum:    68654 510807d792c96e8cc43edf72fcdcc243

  PowerPC architecture:
      Size/MD5 checksum:    69218 d03e4cc71f99c2017a417cf8f073438c

  IBM S/390 architecture:
      Size/MD5 checksum:    69268 dac44abdc98358ccc66c2c3f41bd0965

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb stable/updates main
For dpkg-ftp: dists/stable/updates/main
Mailing list:
Package info: `apt-cache show <pkg>' and<pkg>
Version: GnuPG v1.4.2 (GNU/Linux)


Full-Disclosure - We believe in it.
Hosted and sponsored by Secunia -

- 漏洞信息

Pound add_port() Function Remote Overflow
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

A remote overflow exists in Pound. The add_port() function fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted request, a remote attacker can crash the application resulting in a loss of availability.

- 时间线

2005-04-26 Unknow
2005-04-26 Unknow

- 解决方案

Upgrade to version 1.8.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

APSIS Pound Remote Buffer Overflow Vulnerability
Boundary Condition Error 13436
Yes No
2005-04-29 12:00:00 2009-07-12 02:06:00
Discovery credited to Steven Van Acker <>.

- 受影响的程序版本

S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
APSIS Pound 1.8.2
+ Gentoo Linux
APSIS Pound 1.8.3

- 不受影响的程序版本

APSIS Pound 1.8.3

- 漏洞讨论

APSIS Pound is prone to a remote buffer overflow vulnerability due to insufficient bounds checking on supplied input. Successful exploitation could result in a denial of service or potential arbitrary code execution.

This issue was reported to affect Pound 1.8.2, however, earlier versions may also be vulnerable.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: &lt;;.

- 解决方案

SUSE Linux has released advisory SUSE-SR:2005:015 to address this and other issues. Please see the referenced advisory for more information.

Gentoo has released advisory GLSA 200504-29 to address this issue. Gentoo updates may be applied by running the following commands as the superuser:
emerge --sync
emerge --ask --oneshot --verbose ">=www-servers/pound-1.8.3"

The vendor has addressed this issue in Pound 1.8.3:

APSIS Pound 1.8.2

- 相关参考