发布时间 :2005-05-03 00:00:00
修订时间 :2016-10-17 23:19:41

[原文]Multiple SQL injection vulnerabilities in phpCoin 1.2.2 allow remote attackers to execute arbitrary SQL commands via the (1) search parameter to index.php, (2) phpcoinsessid parameter to login.php, (3) id, (4) dtopic_id, or (5) dcat_id to mod.php.


        phpCoin 1.2.2存在多个SQL注入漏洞,远程攻击者可以通过(1)传给index.php的search参数,(2)传给login.php的phpcoinsessid参数,传给mod.php的(3)id、(4)dtopic_id或(5)dcat_id参数,来执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20050428 Multiple Sql injections in phpCoin v1.2.2 and below
(UNKNOWN)  BID  13433
(UNKNOWN)  VUPEN  ADV-2005-0423
(UNKNOWN)  XF  phpcoin-multiple-sql-injection(20308)

- 漏洞信息

高危 SQL注入
2005-05-03 00:00:00 2009-07-04 00:00:00
        phpCoin 1.2.2存在多个SQL注入漏洞,远程攻击者可以通过(1)传给index.php的search参数,(2)传给login.php的phpcoinsessid参数,传给mod.php的(3)id、(4)dtopic_id或(5)dcat_id参数,来执行任意SQL命令。

- 公告与补丁


- 漏洞信息

phpCOIN login.php phpcoinsessid Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

phpCOIN contains a flaw that may allow a remote attacker to inject arbitrary SQL queries. The issue is due to the 'phpcoinsessid' variable in the 'login.php' script not being properly sanitized and may allow a remote attacker to inject or manipulate SQL queries.

- 时间线

2005-04-28 Unknow
2005-04-28 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

PHPCoin Multiple SQL Injection Vulnerabilities
Input Validation Error 13433
Yes No
2005-04-28 12:00:00 2009-07-12 02:06:00
Discovery of these vulnerabilities is credited to dcrab.

- 受影响的程序版本

phpCOIN phpCOIN 1.2.1 b
phpCOIN phpCOIN 1.2.1
phpCOIN phpCOIN 1.2
Francisco Burzi PHP-Nuke 7.6

- 漏洞讨论

PHPCoin is reportedly affected by multiple SQL injection vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input before using it in SQL queries.

Successful exploitation could result in a compromise of the application, disclosure or modification of data, or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

- 漏洞利用

No exploit is required.

The following proof of concepts are available:''&phpcoinsessid=8d4706204348394afece6b64db3d9b95'&phpcoinsessid=fa7905a749dbdc698838930de0f99f4b'&phpcoinsessid=fa7905a749dbdc698838930de0f99f4b

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考