CVE-2005-1380
CVSS6.8
发布时间 :2005-05-03 00:00:00
修订时间 :2016-10-17 23:19:36
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in BEA Admin Console 8.1 allows remote attackers to execute arbitrary web script or HTML via the server parameter to a JndiFramesetAction action.


[CNNVD]BEA WebLogic Server/Express管理控制台跨站脚本漏洞(CNNVD-200505-829)

        BEA Systems WebLogic包含多种应用系统集成方案,包括Server/Express/Integration等。
        BEA WebLogic Server和WebLogic Express管理控制台中存在远程跨站脚本漏洞,起因是应用程序在动态生成的WEB内容中包含用户提供的输入前没有正确的过滤这些输入。远程攻击者可能利用这个漏洞在用户浏览器中执行任意代码。
        

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:bea:weblogic_server:8.1:sp3:expressBEA Systems WebLogic Express 8.1 SP3
cpe:/a:bea:weblogic_server:8.1::win32
cpe:/a:bea:weblogic_server:8.1:sp3:win32BEA Systems WebLogic Server 8.1 SP3 Win32
cpe:/a:bea:weblogic_server:8.1:sp4:expressBEA Systems WebLogic Express 8.1 SP4
cpe:/a:bea:weblogic_server:8.1::express
cpe:/a:bea:weblogic_server:8.1:sp2:win32BEA Systems WebLogic Server 8.1 SP2 Win32
cpe:/a:bea:weblogic_server:8.1:sp4:win32BEA Systems WebLogic Server 8.1 SP4 Win32
cpe:/a:bea:weblogic_server:8.1:sp1:win32BEA Systems WebLogic Server 8.1 SP1 Win32
cpe:/a:bea:weblogic_server:8.1BEA Systems WebLogic Server 8.1
cpe:/a:bea:weblogic_server:8.1:sp1:expressBEA Systems WebLogic Express 8.1 SP1
cpe:/a:bea:weblogic_server:8.1:sp2:expressBEA Systems WebLogic Express 8.1 SP2
cpe:/a:bea:weblogic_server:8.1:sp1BEA Systems WebLogic Server 8.1 SP1
cpe:/a:bea:weblogic_server:8.1:sp4BEA Systems WebLogic Server 8.1 SP4
cpe:/a:bea:weblogic_server:8.1:sp3BEA Systems WebLogic Server 8.1 SP3
cpe:/a:bea:weblogic_server:8.1:sp2BEA Systems WebLogic Server 8.1 SP2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1380
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1380
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-829
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111472745503010&w=2
(UNKNOWN)  BUGTRAQ  20050428 Cross Site Scripting in BEA Admin Console
http://securitytracker.com/alerts/2005/Apr/1013817.html
(VENDOR_ADVISORY)  SECTRACK  1013817
http://www.red-database-security.com/advisory/bea_css_in_admin_console.html
(VENDOR_ADVISORY)  MISC  http://www.red-database-security.com/advisory/bea_css_in_admin_console.html
http://www.securityfocus.com/bid/13400
(VENDOR_ADVISORY)  BID  13400
http://xforce.iss.net/xforce/xfdb/20276
(VENDOR_ADVISORY)  XF  weblogic-jndiframesetaction-xss(20276)

- 漏洞信息

BEA WebLogic Server/Express管理控制台跨站脚本漏洞
中危 跨站脚本
2005-05-03 00:00:00 2005-10-20 00:00:00
远程  
        BEA Systems WebLogic包含多种应用系统集成方案,包括Server/Express/Integration等。
        BEA WebLogic Server和WebLogic Express管理控制台中存在远程跨站脚本漏洞,起因是应用程序在动态生成的WEB内容中包含用户提供的输入前没有正确的过滤这些输入。远程攻击者可能利用这个漏洞在用户浏览器中执行任意代码。
        

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://commerce.beasys.com/downloads/weblogic_server.jsp

- 漏洞信息

15895
BEA WebLogic Administration Console JndiFramesetAction server Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

BEA WebLogic Administration Console contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'server' variable upon submission to the JndiFramesetAction script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-04-25 2005-04-13
2005-04-25 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

BEA WebLogic Server And WebLogic Express Administration Console Cross-Site Scripting Vulnerability
Input Validation Error 13400
Yes No
2005-04-26 12:00:00 2009-07-12 02:06:00
Discovery of this issue is credited to Alexander Kornbrust.

- 受影响的程序版本

Horde Chora 1.2.2
Horde Chora 1.2.1
Horde Chora 1.2
Horde Chora 1.1
BEA Systems WebLogic Server for Win32 8.1 SP 4
BEA Systems WebLogic Server for Win32 8.1 SP 3
BEA Systems WebLogic Server for Win32 8.1 SP 2
BEA Systems WebLogic Server for Win32 8.1 SP 1
BEA Systems WebLogic Server for Win32 8.1
BEA Systems Weblogic Server 8.1 SP 4
BEA Systems Weblogic Server 8.1 SP 3
BEA Systems Weblogic Server 8.1 SP 2
BEA Systems Weblogic Server 8.1 SP 1
BEA Systems Weblogic Server 8.1
BEA Systems WebLogic Express for Win32 8.1 SP 4
BEA Systems WebLogic Express for Win32 8.1 SP 3
BEA Systems WebLogic Express for Win32 8.1 SP 2
BEA Systems WebLogic Express for Win32 8.1 SP 1
BEA Systems WebLogic Express for Win32 8.1
BEA Systems WebLogic Express 8.1 SP 4
BEA Systems WebLogic Express 8.1 SP 3
BEA Systems WebLogic Express 8.1 SP 2
BEA Systems WebLogic Express 8.1 SP 1
BEA Systems WebLogic Express 8.1
Horde Chora 1.2.3

- 不受影响的程序版本

Horde Chora 1.2.3

- 漏洞讨论

A remote cross-site scripting vulnerability affects BEA WebLogic Server and WebLogic Express administration console. This issue is due to a failure of the application to properly sanitize user-supplied input prior to including it in dynamically generated Web content.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

No exploit is required to leverage this issue. The following example is available:

http://example.com:8001/console/actions/jndi/JndiFramesetAction?server='<script>alert(document.cookie);</script>mydomain%3AName%3Dmyserver%2CType%3DS

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.


Horde Chora 1.1

Horde Chora 1.2

Horde Chora 1.2.1

Horde Chora 1.2.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站