CVE-2005-1312
CVSS7.5
发布时间 :2005-04-24 00:00:00
修订时间 :2008-09-05 16:48:48
NMCO    

[原文]PHP remote file inclusion vulnerability in Yappa-NG before 2.3.2 allows remote attackers to execute arbitrary PHP code via unknown vectors.


[CNNVD]PHP Yappa-NG未明远程文件包含漏洞(CNNVD-200504-091)

        yappa-ng是一个非常强大但非常易于安装和使用的在线PHP相册。支持所有操作系统 (Linux/UNIX,Windows,MAC, ...),和所有Web服务器(Apache,IIS,...)并且不需要数据库支持。每一张图片都可以以多种不同的尺寸进行查看,并且缩略图和所有其它调整大小都将自动快速创建。yappa-ng支持为相册设置密码保护,统计图片点击,设置图片评论功能。
        Yappa-NG的2.3.2之前版本存在PHP远程文件包含漏洞, 远程攻击者可以通过未知向量来执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:yappa-ng:yappa-ng:2.3.1
cpe:/a:yappa-ng:yappa-ng:2.2.2
cpe:/a:yappa-ng:yappa-ng:2.0.1
cpe:/a:yappa-ng:yappa-ng:2.2.1
cpe:/a:yappa-ng:yappa-ng:2.3.0
cpe:/a:yappa-ng:yappa-ng:1.3
cpe:/a:yappa-ng:yappa-ng:1.0
cpe:/a:yappa-ng:yappa-ng:2.0.0
cpe:/a:yappa-ng:yappa-ng:1.2
cpe:/a:yappa-ng:yappa-ng:1.6
cpe:/a:yappa-ng:yappa-ng:0.9
cpe:/a:yappa-ng:yappa-ng:2.2.0
cpe:/a:yappa-ng:yappa-ng:1.5
cpe:/a:yappa-ng:yappa-ng:2.1.0
cpe:/a:yappa-ng:yappa-ng:1.1
cpe:/a:yappa-ng:yappa-ng:1.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1312
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1312
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200504-091
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/13371
(PATCH)  BID  13371
http://secunia.com/advisories/15107
(PATCH)  SECUNIA  15107
http://www.osvdb.org/15829
(UNKNOWN)  OSVDB  15829
http://sourceforge.net/project/shownotes.php?release_id=323206
(UNKNOWN)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=323206

- 漏洞信息

PHP Yappa-NG未明远程文件包含漏洞
高危 输入验证
2005-04-24 00:00:00 2006-09-28 00:00:00
远程  
        yappa-ng是一个非常强大但非常易于安装和使用的在线PHP相册。支持所有操作系统 (Linux/UNIX,Windows,MAC, ...),和所有Web服务器(Apache,IIS,...)并且不需要数据库支持。每一张图片都可以以多种不同的尺寸进行查看,并且缩略图和所有其它调整大小都将自动快速创建。yappa-ng支持为相册设置密码保护,统计图片点击,设置图片评论功能。
        Yappa-NG的2.3.2之前版本存在PHP远程文件包含漏洞, 远程攻击者可以通过未知向量来执行任意PHP代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        yappa-ng yappa-ng 0.9
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 1.0
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 1.1
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 1.2
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 1.3
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 1.4
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 1.5
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 1.6
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 2.0 .0
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 2.0.1
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 2.1 .0
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 2.2 .0
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 2.2.1
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 2.2.2
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 2.3 .0
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        yappa-ng yappa-ng 2.3.1
        yappa-ng yappa-ng 2.3.2
        http://sourceforge.net/project/showfiles.php?group_id=70802
        

- 漏洞信息

15829
yappa-ng Unspecified Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Unknown Vendor Verified

- 漏洞描述

yappa-ng contains a flaw that may allow a remote attacker to include a file from a remote host that contains arbitrary commands which will be executed by a vulnerable script. No further details have been provided.

- 时间线

2005-04-24 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.3.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站