CVE-2005-1306
CVSS5.0
发布时间 :2005-06-15 00:00:00
修订时间 :2008-09-05 16:48:47
NMCOS    

[原文]The Adobe Reader control in Adobe Reader and Acrobat 7.0 and 7.0.1 allows remote attackers to determine the existence of files via Javascript containing XML script, aka the "XML External Entity vulnerability."


[CNNVD]Adobe Acrobat/Adobe Reader 文件泄露漏洞(CNNVD-200506-131)

        Adobe Reader(之前被称为Acrobat Reader)是非常流行的PDF文本阅读器。
        Adobe Reader在处理XML外部实体(XXE)时存在漏洞,攻击者可能利用此漏洞非授权读取某些文件。
        攻击者可以在PDF文件中引入JavaScript,然后让这个JavaScript解析引用了外部实体的嵌入XML文档,导致读取本地电脑中某些类型的文本文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:adobe:acrobat_reader:7.0Adobe Acrobat Reader 7.0
cpe:/a:adobe:acrobat_reader:7.0.1Adobe Acrobat Reader 7.0.1
cpe:/a:adobe:acrobat:7.0.1Adobe Acrobat 7.0.1
cpe:/a:adobe:acrobat:7.0Adobe Acrobat 7.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1306
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1306
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-131
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/13962
(VENDOR_ADVISORY)  BID  13962
http://www.adobe.com/support/techdocs/331710.html
(VENDOR_ADVISORY)  CONFIRM  http://www.adobe.com/support/techdocs/331710.html

- 漏洞信息

Adobe Acrobat/Adobe Reader 文件泄露漏洞
中危 设计错误
2005-06-15 00:00:00 2005-10-20 00:00:00
远程  
        Adobe Reader(之前被称为Acrobat Reader)是非常流行的PDF文本阅读器。
        Adobe Reader在处理XML外部实体(XXE)时存在漏洞,攻击者可能利用此漏洞非授权读取某些文件。
        攻击者可以在PDF文件中引入JavaScript,然后让这个JavaScript解析引用了外部实体的嵌入XML文档,导致读取本地电脑中某些类型的文本文件。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.adobe.com/support/downloads/

- 漏洞信息

17325
Adobe Reader/Acrobat XML Script Local File Enumeration
Local Access Required
Loss of Confidentiality Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2005-06-15 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 7.0.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Adobe Acrobat/Adobe Reader File Existence and Disclosure Vulnerability
Design Error 13962
Yes No
2005-06-15 12:00:00 2009-07-12 04:06:00
Sverre H. Huseby is credited with the discovery of this issue.

- 受影响的程序版本

Adobe Reader 7.0.1
Adobe Reader 7.0
Adobe Acrobat 7.0.1
Adobe Acrobat 7.0
Adobe Reader 7.0.2
Adobe Acrobat 7.0.2

- 不受影响的程序版本

Adobe Reader 7.0.2
Adobe Acrobat 7.0.2

- 漏洞讨论

Adobe Acrobat and Adobe Reader may allow remote attackers to determine the existence of files on a vulnerable computer. This issue can be used to disclose data from a target file as well.

Information gathered through the exploitation of this vulnerability may aid in other attacks.

- 漏洞利用

An exploit is not required.

The following proof of concept is available:
<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE foo [
<!ELEMENT foo ANY>
<!ENTITY xxe SYSTEM "c:/boot.ini">
]>
<foo>&xxe;</foo>

More proof of concept examples are available at the following location:
http://shh.thathost.com/secadv/adobexxe/

- 解决方案

The vendor has released upgrades to address this issue.


Adobe Acrobat 7.0

Adobe Reader 7.0

Adobe Reader 7.0.1

Adobe Acrobat 7.0.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站