CVE-2005-1290
CVSS4.3
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:18:37
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in phpBB 2.0.14 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) u parameter to profile.php, (2) highlight parameter to viewtopic.php, or (3) forumname or forumdesc parameters to admin_forums.php.


[CNNVD]phpBB 跨站脚本攻击漏洞(CNNVD-200505-140)

        phpBB 2.0.14以及较早版本中存在多个跨站脚本攻击(XSS)漏洞,允许远程攻击者通过(1)profile.php的u参数,(2)viewtopic.php的highlight参数或者(3)admin_forums.php的forumname或forumdesc参数来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpbb_group:phpbb:2.0.12
cpe:/a:phpbb_group:phpbb:2.0.4
cpe:/a:phpbb_group:phpbb:2.0.11
cpe:/a:phpbb_group:phpbb:2.0.5
cpe:/a:phpbb_group:phpbb:2.0.10
cpe:/a:phpbb_group:phpbb:2.0.2
cpe:/a:phpbb_group:phpbb:2.0.3
cpe:/a:phpbb_group:phpbb:2.0.0
cpe:/a:phpbb_group:phpbb:2.0.1
cpe:/a:phpbb_group:phpbb:2.0.8a
cpe:/a:phpbb_group:phpbb:2.0.8
cpe:/a:phpbb_group:phpbb:2.0.9
cpe:/a:phpbb_group:phpbb:2.0.14
cpe:/a:phpbb_group:phpbb:2.0.6
cpe:/a:phpbb_group:phpbb:2.0.13
cpe:/a:phpbb_group:phpbb:2.0.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1290
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1290
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-140
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111428283721756&w=2
(UNKNOWN)  BUGTRAQ  20050423 -==phpBB 2.0.14 Multiple Vulnerabilities==-
http://neosecurityteam.net/Advisories/Advisory-14.txt
(UNKNOWN)  MISC  http://neosecurityteam.net/Advisories/Advisory-14.txt

- 漏洞信息

phpBB 跨站脚本攻击漏洞
中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        phpBB 2.0.14以及较早版本中存在多个跨站脚本攻击(XSS)漏洞,允许远程攻击者通过(1)profile.php的u参数,(2)viewtopic.php的highlight参数或者(3)admin_forums.php的forumname或forumdesc参数来注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

15919
phpBB admin_forums.php forumname Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown
Exploit Public

- 漏洞描述

phpBB contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'forumname' variable upon submission to the 'admin_forums.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-04-23 Unknow
2005-04-23 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站