CVE-2005-1245
CVSS4.3
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:48:38
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in MediaWiki before 1.4.2, when using HTML Tidy ($wgUseTidy), allows remote attackers to inject arbitrary web script or HTML via unknown vectors.


[CNNVD]MediaWiki HTML Tidy 跨站脚本攻击漏洞(CNNVD-200505-314)

        MediaWiki 1.4.2之前的版本中存在跨站脚本攻击(XSS)漏洞,当使用HTML Tidy($wgUseTidy)时,允许远程攻击者通过未知向量注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mediawiki:mediawiki:1.3.3MediaWiki 1.3.3
cpe:/a:mediawiki:mediawiki:1.4_beta5
cpe:/a:mediawiki:mediawiki:1.3.2MediaWiki 1.3.2
cpe:/a:mediawiki:mediawiki:1.3.7MediaWiki 1.3.7
cpe:/a:mediawiki:mediawiki:1.3.11MediaWiki 1.3.11
cpe:/a:mediawiki:mediawiki:1.4_beta4
cpe:/a:mediawiki:mediawiki:1.3.10MediaWiki 1.3.10
cpe:/a:mediawiki:mediawiki:1.3.8MediaWiki 1.3.8
cpe:/a:mediawiki:mediawiki:1.3.6MediaWiki 1.3.6
cpe:/a:mediawiki:mediawiki:1.4_beta3
cpe:/a:mediawiki:mediawiki:1.3.1MediaWiki 1.3.1
cpe:/a:mediawiki:mediawiki:1.3.5MediaWiki 1.3.5
cpe:/a:mediawiki:mediawiki:1.4_beta2
cpe:/a:mediawiki:mediawiki:1.3.9MediaWiki 1.3.9
cpe:/a:mediawiki:mediawiki:1.4_beta1
cpe:/a:mediawiki:mediawiki:1.3MediaWiki 1.3
cpe:/a:mediawiki:mediawiki:1.3.4MediaWiki 1.3.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1245
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1245
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-314
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/13301
(PATCH)  BID  13301
http://sourceforge.net/project/shownotes.php?release_id=322146
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=322146
http://secunia.com/advisories/14993
(PATCH)  SECUNIA  14993
http://xforce.iss.net/xforce/xfdb/20210
(UNKNOWN)  XF  mediawiki-unknown-xss(20210)
http://www.osvdb.org/15719
(UNKNOWN)  OSVDB  15719

- 漏洞信息

MediaWiki HTML Tidy 跨站脚本攻击漏洞
中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        MediaWiki 1.4.2之前的版本中存在跨站脚本攻击(XSS)漏洞,当使用HTML Tidy($wgUseTidy)时,允许远程攻击者通过未知向量注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://prdownloads.sourceforge.net/wikipedia/mediawiki-1.4.2.tar.gz?download

- 漏洞信息

15719
MediaWiki $wgUseTidy Output Processing XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

MediaWiki contains a flaw that allows a remote cross site scripting attack. This flaw, which affects MSIE clients only, exists if MediaWiki has been configured to output through HTML Tidy ($wgUseTidy) and is caused by the application not properly validating user input. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-04-20 Unknow
2005-04-20 Unknow

- 解决方案

Upgrade to version 1.3.12, 1.4.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站