CVE-2005-1194
CVSS4.6
发布时间 :2005-05-04 00:00:00
修订时间 :2010-08-21 00:28:02
NMCOS    

[原文]Stack-based buffer overflow in the ieee_putascii function for nasm 0.98 and earlier allows attackers to execute arbitrary code via a crafted asm file, a different vulnerability than CVE-2004-1287.


[CNNVD]NASM IEEE_PUTASCII远程缓冲区溢出漏洞(CNNVD-200505-901)

        nasm 0.98及更早版本的ieee_putascii函数存在基于栈的缓冲区溢出,远程攻击者可以通过一个特制的asm文件,来执行任意代码。是不同于CVE-2004-1287的漏洞。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:redhat:linux_advanced_workstation:2.1::ia64
cpe:/o:redhat:enterprise_linux_desktop:4.0Red Hat Desktop 4.0
cpe:/o:redhat:enterprise_linux:4.0::advanced_server
cpe:/o:redhat:enterprise_linux_desktop:3.0Red Hat Desktop 3.0
cpe:/o:redhat:enterprise_linux:3.0::workstation
cpe:/o:redhat:enterprise_linux:3.0::enterprise_server
cpe:/o:redhat:enterprise_linux:3.0::advanced_servers
cpe:/o:redhat:enterprise_linux:4.0::enterprise_server
cpe:/o:redhat:enterprise_linux:2.1::workstation
cpe:/o:redhat:enterprise_linux:2.1::advanced_server
cpe:/o:redhat:enterprise_linux:4.0::workstation
cpe:/o:redhat:enterprise_linux:2.1::enterprise_server

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:11256Stack-based buffer overflow in the ieee_putascii function for nasm 0.98 and earlier allows attackers to execute arbitrary code via a crafted...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1194
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1194
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-901
(官方数据源) CNNVD

- 其它链接及资源

http://www.redhat.com/support/errata/RHSA-2005-381.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2005:381
http://www.securityfocus.com/bid/13506
(UNKNOWN)  BID  13506

- 漏洞信息

NASM IEEE_PUTASCII远程缓冲区溢出漏洞
中危 缓冲区溢出
2005-05-04 00:00:00 2005-10-25 00:00:00
远程  
        nasm 0.98及更早版本的ieee_putascii函数存在基于栈的缓冲区溢出,远程攻击者可以通过一个特制的asm文件,来执行任意代码。是不同于CVE-2004-1287的漏洞。

- 公告与补丁

        暂无数据

- 漏洞信息

16088
NASM ieee_putascii() Function ASM File Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-04-21 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

NASM IEEE_PUTASCII Remote Buffer Overflow Vulnerability
Boundary Condition Error 13506
Yes No
2005-05-05 12:00:00 2007-03-01 08:16:00
This issue was reported by Josh Bressers.

- 受影响的程序版本

Ubuntu Ubuntu Linux 5.0 4 powerpc
Ubuntu Ubuntu Linux 5.0 4 i386
Ubuntu Ubuntu Linux 5.0 4 amd64
Ubuntu Ubuntu Linux 4.1 ppc
Ubuntu Ubuntu Linux 4.1 ia64
Ubuntu Ubuntu Linux 4.1 ia32
SGI ProPack 3.0
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux WS 2.1 IA64
RedHat Enterprise Linux WS 2.1
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Enterprise Linux ES 2.1 IA64
RedHat Enterprise Linux ES 2.1
RedHat Desktop 4.0
RedHat Desktop 3.0
RedHat Advanced Workstation for the Itanium Processor 2.1 IA64
RedHat Advanced Workstation for the Itanium Processor 2.1
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
Red Hat Enterprise Linux AS 2.1 IA64
Red Hat Enterprise Linux AS 2.1
NASM NASM 0.98.38
+ Gentoo Linux 1.4
+ Gentoo Linux
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Mandriva Linux Mandrake 10.0 AMD64
+ Mandriva Linux Mandrake 10.0
+ Red Hat Fedora Core3
NASM NASM 0.98.35
NASM NASM 0.98.34
+ Turbolinux Home
+ Turbolinux Turbolinux Desktop 10.0
+ Turbolinux Turbolinux Server 10.0
+ Turbolinux Turbolinux Server 8.0
Mandriva Linux Mandrake 10.2 x86_64
Mandriva Linux Mandrake 10.2
Mandriva Linux Mandrake 10.1 x86_64
Mandriva Linux Mandrake 10.1
Mandriva Linux Mandrake 10.0 AMD64
Mandriva Linux Mandrake 10.0
MandrakeSoft Corporate Server 3.0 x86_64
MandrakeSoft Corporate Server 3.0
MandrakeSoft Corporate Server 2.1 x86_64
MandrakeSoft Corporate Server 2.1

- 漏洞讨论

NASM is prone to a remote buffer-overflow vulnerability. This issue affects the 'ieee_putascii()' function.

An attacker likely exploits this issue by crafting a malicious source file to be assembled by the application. This file is sent to an affected user; if the user loads the file in NASM, the attack may result in arbitrary code execution.

The attacker may then gain unauthorized access in the context of the user running NASM.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: mailto:vuldb@securityfocus.com.

- 解决方案

Please see the referenced advisories for more information.


NASM NASM 0.98.38

Mandriva Linux Mandrake 10.0

Mandriva Linux Mandrake 10.0 AMD64

Mandriva Linux Mandrake 10.1

Mandriva Linux Mandrake 10.1 x86_64

Mandriva Linux Mandrake 10.2 x86_64

Mandriva Linux Mandrake 10.2

MandrakeSoft Corporate Server 2.1

MandrakeSoft Corporate Server 2.1 x86_64

MandrakeSoft Corporate Server 3.0 x86_64

MandrakeSoft Corporate Server 3.0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站