CVE-2005-1171
CVSS4.3
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:17:50
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in mod.php in the datenbank module for phpBB allows remote attackers to inject arbitrary web script or HTML via the id parameter.


[CNNVD]Datenbank Module For PHPBB Remote Mod.PHP跨站脚本漏洞(CNNVD-200505-054)

        phpBB datenbank模块的mod.php存在跨站脚本攻击(XSS)漏洞,可让远程攻击者通过ID参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1171
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1171
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-054
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111367077709726&w=2
(UNKNOWN)  BUGTRAQ  20050416 phpBB datenbank mod has XSS/SQL Injection in the id variable
http://www.securityfocus.com/bid/13210
(UNKNOWN)  BID  13210
http://xforce.iss.net/xforce/xfdb/20146
(UNKNOWN)  XF  phpbb-modphp-xss(20146)

- 漏洞信息

Datenbank Module For PHPBB Remote Mod.PHP跨站脚本漏洞
中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        phpBB datenbank模块的mod.php存在跨站脚本攻击(XSS)漏洞,可让远程攻击者通过ID参数注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

15812
phpBB datenbank Module mod.php id Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpBB datenbank Module contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'id' variable upon submission to the 'mod.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-04-16 Unknow
2005-04-16 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Datenbank Module For PHPBB Remote Mod.PHP Cross-Site Scripting Vulnerability
Input Validation Error 13210
Yes No
2005-04-16 12:00:00 2009-07-12 12:56:00
tom cruise <the.n3t@gmail.com> is credited with the discovery of this issue.

- 受影响的程序版本

Datenbank Module for phpbb

- 漏洞讨论

A remote cross-site scripting vulnerability affects the datenbank module for phpbb. This issue is due to a failure of the application to properly sanitize user-supplied input prior to including it in dynamically generated Web content.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

No exploit is required to leverage this issue. The following proof of concept has been provided:

http://www.example.com/phpBB/moddb/mod.php?id='&gt;&amp;lt;script&amp;gt;alert(document.cookie)&amp;lt;/script&amp;gt;

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站