发布时间 :2005-04-12 00:00:00
修订时间 :2008-09-05 16:48:18

[原文]Cross-site scripting (XSS) vulnerability in index.php in Pinnacle Cart allows remote attackers to inject arbitrary web script or HTML via the pg parameter.

[CNNVD]Pinnacle Cart Index.PHP跨站脚本攻击漏洞(CNNVD-200504-020)

        Pinnacle Cart 是功能强大的PHP购物车软件和建站工具。符合市场潮流,此款电子商务软件功能强大、易用,兼备灵活性。
        Pinnacle Cart的index.php文件中存在跨站脚本(XSS)漏洞。远程攻击者可以借助于pg参数注入任意的web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  pinnaclecart-index-xss(20092)

- 漏洞信息

Pinnacle Cart Index.PHP跨站脚本攻击漏洞
中危 跨站脚本
2005-04-12 00:00:00 2006-05-04 00:00:00
        Pinnacle Cart 是功能强大的PHP购物车软件和建站工具。符合市场潮流,此款电子商务软件功能强大、易用,兼备灵活性。
        Pinnacle Cart的index.php文件中存在跨站脚本(XSS)漏洞。远程攻击者可以借助于pg参数注入任意的web脚本或HTML。

- 公告与补丁


- 漏洞信息

Pinnacle Cart index.php pg Parameter XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Pinnacle Cart contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'pg' variables upon submission to the index.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-04-12 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Pinnacle Cart Index.PHP Cross-Site Scripting Vulnerability
Input Validation Error 13138
Yes No
2005-04-12 12:00:00 2007-02-22 03:06:00
SmOk3 [] is credited with the discovery of this vulnerability.

- 受影响的程序版本

Pinnacle Cart Pinnacle Cart
Pinnacle Cart Pinnacle Cart 3.5

- 不受影响的程序版本

Pinnacle Cart Pinnacle Cart 3.5

- 漏洞讨论

Pinnacle Cart is affected by a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

- 漏洞利用

No exploit is required.

The following proof of concept is available:"><script>alert(document.domain);</script>

- 解决方案

The vendor has released version 3.5 to address this issue; please contact the vendor for information regarding product upgrades.

- 相关参考