CVE-2005-1120
CVSS4.3
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:48:16
NMCOS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in IlohaMail 0.8.14 and earlier allow remote attackers to inject arbitrary web script or HTML via the e-mail (1) body, (2) filename, or (3) MIME type.


[CNNVD]IlohaMail Email多个跨站脚本攻击漏洞(CNNVD-200505-519)

        IlohaMail 0.8.14及更早版本存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可以通过电子邮件(1)正文,(2)文件名或(3)MIME类型注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ilohamail:ilohamail:0.8.14_rc2
cpe:/a:ilohamail:ilohamail:0.7.1
cpe:/a:ilohamail:ilohamail:0.8.8
cpe:/a:ilohamail:ilohamail:0.7.9
cpe:/a:ilohamail:ilohamail:0.8.12
cpe:/a:ilohamail:ilohamail:0.8.11
cpe:/a:ilohamail:ilohamail:0.8.14_rc1
cpe:/a:ilohamail:ilohamail:0.7.4.2
cpe:/a:ilohamail:ilohamail:0.8.9
cpe:/a:ilohamail:ilohamail:0.7.8
cpe:/a:ilohamail:ilohamail:0.7.5
cpe:/a:ilohamail:ilohamail:0.7.0
cpe:/a:ilohamail:ilohamail:0.7.6
cpe:/a:ilohamail:ilohamail:0.7.4
cpe:/a:ilohamail:ilohamail:0.8.6
cpe:/a:ilohamail:ilohamail:0.8.7
cpe:/a:ilohamail:ilohamail:0.8.13
cpe:/a:ilohamail:ilohamail:0.7.7
cpe:/a:ilohamail:ilohamail:0.8.10
cpe:/a:ilohamail:ilohamail:0.7.3
cpe:/a:ilohamail:ilohamail:0.7.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1120
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1120
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-519
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/20095
(UNKNOWN)  XF  ilohamail-mail-attached-file-xss(20095)
http://www.securityfocus.com/bid/13175
(UNKNOWN)  BID  13175
http://secunia.com/advisories/14957
(VENDOR_ADVISORY)  SECUNIA  14957
http://www.osvdb.org/15506
(UNKNOWN)  OSVDB  15506
http://www.debian.org/security/2006/dsa-1010
(UNKNOWN)  DEBIAN  DSA-1010
http://securitytracker.com/id?1013701
(UNKNOWN)  SECTRACK  1013701
http://secunia.com/advisories/19266
(UNKNOWN)  SECUNIA  19266

- 漏洞信息

IlohaMail Email多个跨站脚本攻击漏洞
中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        IlohaMail 0.8.14及更早版本存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可以通过电子邮件(1)正文,(2)文件名或(3)MIME类型注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

15506
IlohaMail read_message.php Attachment Multiple Field Script Insertion
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Exploit Unknown Vendor Verified

- 漏洞描述

IlohaMail contains a flaw which can be exploited by malicious people to conduct script insertion attacks. This flaw exists due to an input validation error in the read_message.php script when processing mails where the body, filename and MIME media type of attachments isn't properly sanitized before being displayed. This could allow a user to create a specially crafted mail that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-04-14 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.8.14-RC3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

IlohaMail Email Message Remote HTML Injection Vulnerability
Input Validation Error 13175
Yes No
2005-04-14 12:00:00 2006-07-19 06:47:00
Ulf Härnhammar is credited with the discovery if this vulnerability.

- 受影响的程序版本

IlohaMail IlohaMail 0.8.14 RC2
IlohaMail IlohaMail 0.8.14 RC1
IlohaMail IlohaMail 0.8.14
IlohaMail IlohaMail 0.8.13
IlohaMail IlohaMail 0.8.12
IlohaMail IlohaMail 0.8.11
IlohaMail IlohaMail 0.8.10
IlohaMail IlohaMail 0.8.9
IlohaMail IlohaMail 0.8.8
IlohaMail IlohaMail 0.8.7
IlohaMail IlohaMail 0.8.6
IlohaMail IlohaMail 0.7.9
IlohaMail IlohaMail 0.7.8
IlohaMail IlohaMail 0.7.7
IlohaMail IlohaMail 0.7.6
IlohaMail IlohaMail 0.7.5
IlohaMail IlohaMail 0.7.4 -2
IlohaMail IlohaMail 0.7.4
IlohaMail IlohaMail 0.7.3
IlohaMail IlohaMail 0.7.2
IlohaMail IlohaMail 0.7.1
IlohaMail IlohaMail 0.7 .0
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

IlohaMail is affected by an HTML-injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in dynamically generated content.

Attacker-supplied HTML and script code would be able to access properties of the site, potentially allowing for theft of cookie-based authentication credentials. An attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible.

- 漏洞利用

No exploit is required.

- 解决方案

Please see the referenced vendor advisories for more information and fixes.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.commailto:vuldb@securityfocus.com.


IlohaMail IlohaMail 0.8.14

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站