CVE-2005-1112
CVSS5.0
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:17:21
NMCO    

[原文]IBM WebSphere Application Server 6.0 and earlier, when sharing the document root of the web server, allows remote attackers to obtain the source code for Java Server Pages (.jsp) via an HTTP request with an invalid Host header, which causes the page to be processed by the web server instead of the JSP engine.


[CNNVD]IBM WebSphere Application Server Web泄露漏洞(CNNVD-200505-728)

        IBM WebSphere Application Server 6.0及更早版本,在共享web服务器的文档root时,远程攻击者可以通过带有无效主机标题的HTTP请求,导致web服务器而非JSP引擎来处理该页面,从而获取Java Server Pages (.jsp)的源代码。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:ibm:websphere_application_server:5.0.2.5IBM WebSphere Application Server 5.0.2.5
cpe:/a:ibm:websphere_application_server:5.0.2.6IBM WebSphere Application Server 5.0.2.6
cpe:/a:ibm:websphere_application_server:5.0.2.3IBM WebSphere Application Server 5.0.2.3
cpe:/a:ibm:websphere_application_server:5.0.2.4IBM WebSphere Application Server 5.0.2.4
cpe:/a:ibm:websphere_application_server:5.0.2.9IBM WebSphere Application Server 5.0.2.9
cpe:/a:ibm:websphere_application_server:6.0IBM WebSphere Application Server 6.0
cpe:/a:ibm:websphere_application_server:5.0.2IBM WebSphere Application Server 5.0.2
cpe:/a:ibm:websphere_application_server:5.0.2.7IBM WebSphere Application Server 5.0.2.7
cpe:/a:ibm:websphere_application_server:5.1.1IBM WebSphere Application Server 5.1.1
cpe:/a:ibm:websphere_application_server:5.0.1IBM WebSphere Application Server 5.0.1
cpe:/a:ibm:websphere_application_server:5.0.2.8IBM WebSphere Application Server 5.0.2.8
cpe:/a:ibm:websphere_application_server:5.1.0IBM WebSphere Application Server 5.1.0
cpe:/a:ibm:websphere_application_server:5.0.2.1IBM WebSphere Application Server 5.0.2.1
cpe:/a:ibm:websphere_application_server:5.1.0.2IBM WebSphere Application Server 5.1.0.2
cpe:/a:ibm:websphere_application_server:5.1.1.1IBM WebSphere Application Server 5.1.1.1
cpe:/a:ibm:websphere_application_server:5.1.1.2IBM WebSphere Application Server 5.1.1.2
cpe:/a:ibm:websphere_application_server:5.0IBM WebSphere Application Server 5.0
cpe:/a:ibm:websphere_application_server:5.1.0.4IBM WebSphere Application Server 5.1.0.4
cpe:/a:ibm:websphere_application_server:5.1.1.3IBM WebSphere Application Server 5.1.1.3
cpe:/a:ibm:websphere_application_server:5.1.0.5IBM WebSphere Application Server 5.1.0.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1112
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1112
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-728
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111342594129109&w=2
(UNKNOWN)  BUGTRAQ  20050413 IBM WebSphere Widespread configuration JSP disclosure
http://securitytracker.com/id?1013697
(VENDOR_ADVISORY)  SECTRACK  1013697
http://www.securityfocus.com/bid/13160
(UNKNOWN)  BID  13160
http://xforce.iss.net/xforce/xfdb/20099
(UNKNOWN)  XF  ibm-websphere-information-disclosure(20099)

- 漏洞信息

IBM WebSphere Application Server Web泄露漏洞
中危 访问验证错误
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        IBM WebSphere Application Server 6.0及更早版本,在共享web服务器的文档root时,远程攻击者可以通过带有无效主机标题的HTTP请求,导致web服务器而非JSP引擎来处理该页面,从而获取Java Server Pages (.jsp)的源代码。

- 公告与补丁

        暂无数据

- 漏洞信息

15501
IBM WebSphere Application Server (WAS) Malformed Host: Header JSP Source Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality Solution Unknown
Exploit Public

- 漏洞描述

IBM WebSphere Application Server contains a flaw that may lead to an unauthorized information disclosure on system configurations where the document root of the web server is the same as the document root of the application server. The issue is triggered when a remote user sends a specially crafted HTTP GET request with a non-existing "Host" header value, which will disclose the source of JSP scripts resulting in a loss of confidentiality.

- 时间线

2005-04-13 Unknow
2005-04-13 Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to correct the flaw by implementing the following workaround(s): It is recommended to move the WebSphere Application Server JSP source files outside of the web server document root.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站