发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:17:11

[原文]Multiple buffer overflows in Lotus Domino Server 6.0.5 and 6.5.4 allow remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via large amounts of data in certain (1) time or (2) date fields.

[CNNVD]IBM Lotus Domino Server畸形POST请求远程溢出漏洞(CNNVD-200505-376)

        IBM Lotus Domino Server软件可在各种操作系统上提供消息,日程安排等功能。
        Lotus Domino Server中存在缓冲区溢出漏洞,如果攻击者能够向特定的时间/日期字段提交畸形的POST请求的话,就可以导致服务器崩溃。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:ibm:lotus_domino_server:6.5.4IBM Lotus Domino Server 6.5.4
cpe:/a:ibm:lotus_domino_server:6.0.5IBM Lotus Domino Server 6.0.5

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20050412 Remote Buffer Overflow in Lotus Domino
(PATCH)  XF  lotus-timedate-bo(20042)

- 漏洞信息

IBM Lotus Domino Server畸形POST请求远程溢出漏洞
高危 缓冲区溢出
2005-05-02 00:00:00 2005-10-20 00:00:00
        IBM Lotus Domino Server软件可在各种操作系统上提供消息,日程安排等功能。
        Lotus Domino Server中存在缓冲区溢出漏洞,如果攻击者能够向特定的时间/日期字段提交畸形的POST请求的话,就可以导致服务器崩溃。

- 公告与补丁


- 漏洞信息

IBM Lotus Domino Server time/date Fields Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

- 时间线

2005-04-05 Unknow
Unknow Unknow

- 解决方案


Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

IBM Lotus Domino Server Malformed POST Request Remote Buffer Overflow Vulnerability
Boundary Condition Error 13130
Yes No
2005-04-12 12:00:00 2009-07-12 12:56:00
Discovery is credited to Mark Litchfield of NGSSoftware.

- 受影响的程序版本

IBM Lotus Domino 6.5.3
IBM Lotus Domino 6.5.2
IBM Lotus Domino 6.5.1
IBM Lotus Domino 6.5 .0
IBM Lotus Domino 6.0.3
IBM Lotus Domino 6.0.2 CF2
IBM Lotus Domino 6.0.2
IBM Lotus Domino 6.0.1
IBM Lotus Domino 6.0
IBM Lotus Domino 6.5.4
IBM Lotus Domino 6.0.5

- 不受影响的程序版本

IBM Lotus Domino 6.5.4
IBM Lotus Domino 6.0.5

- 漏洞讨论

Lotus Domino Server is reported prone to a remote buffer overflow vulnerability.

The issue presents itself when the server handles a malformed HTTP POST request.

A successful attack may result in a denial of service condition, however, arbitrary code execution may occur as well. This issue may be leveraged to gain unauthorized access to a server.

IBM Lotus Domino Server versions 6.5.x and 6.0.x are reported vulnerable. The researcher responsible for discovering this issue has reported that this vulnerability affects versions 6.0.5 and 6.5.4. IBM Lotus Domino Server versions 6.0.5 and 6.5.4 were recently released, therefore it is likely that they are not affected and this issue only manifests in the versions prior to these. IBM also recommends that users should upgrade to these versions. Please see the referenced IBM advisory for more information.

This BID will be updated when more details are available.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

IBM has released an advisory to address this issue. Please see the referenced advisory for more information.

- 相关参考