发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:48:11

[原文]Cross-site scripting (XSS) vulnerability in main.asp for Ocean12 Membership Manager Pro 1.x allows remote attackers to inject arbitrary web script or HTML via the page parameter.

[CNNVD]Ocean12 Membership Manager Pro 跨站脚本攻击漏洞(CNNVD-200505-553)

        Ocean12 Membership Manager Pro 1.x中main.asp存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过页面参数来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  ocean12-membershipmgr-mainasp-xss(20014)
(UNKNOWN)  BID  13046

- 漏洞信息

Ocean12 Membership Manager Pro 跨站脚本攻击漏洞
中危 跨站脚本
2005-05-02 00:00:00 2006-08-28 00:00:00
        Ocean12 Membership Manager Pro 1.x中main.asp存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过页面参数来注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

Ocean12 Membership Manager main.asp page Parameter XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Ocean12 Membership Manager contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'page' variable upon submission to the main.asp script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-04-04 Unknow
2005-04-04 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Ocean12 Membership Manager Pro Cross-Site Scripting Vulnerability
Input Validation Error 13046
Yes No
2005-04-06 12:00:00 2009-07-12 12:56:00
Discovery of this vulnerability is credited to "Zinho" <>.

- 受影响的程序版本

Ocean12 Technologies Membership Manager Pro

- 漏洞讨论

Ocean12 Membership Manager Pro is reportedly affected by a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

No exploit is required.

The following proof of concept URI is available:;page=%22%3E%3Cscript%3Ealert(document.cookie)%3C/script%3E%3Cfont%20color=%22&amp;Sort=Name&amp;DisplayNumber=10

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考