CVE-2005-1093
CVSS7.5
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:48:11
NMCOS    

[原文]Buffer overflow in the PopUp Plus 2.0.3.8 plugin for Miranda IM, with "Use SmileyAdd Setting" enabled, allows remote attackers to execute arbitrary code.


[CNNVD]针对Miranda Instant Messenger的PopUp Plus远程缓冲区溢出漏洞(CNNVD-200505-260)

        针对Miranda IM的PopUp Plus 2.0.3.8插件在启用"Use SmileyAdd Setting"的情况下,其存在的缓冲区溢出漏洞允许远程攻击者执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1093
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1093
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-260
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/13048
(PATCH)  BID  13048
http://forums.miranda-im.org/showthread.php?p=9624
(PATCH)  CONFIRM  http://forums.miranda-im.org/showthread.php?p=9624
http://xforce.iss.net/xforce/xfdb/20013
(UNKNOWN)  XF  popupplus-message-bo(20013)
http://www.osvdb.org/15482
(UNKNOWN)  OSVDB  15482
http://www.miranda-im.org/
(UNKNOWN)  CONFIRM  http://www.miranda-im.org/
http://securitytracker.com/id?1013661
(UNKNOWN)  SECTRACK  1013661
http://sec.org.il/coverages.php?c=89
(VENDOR_ADVISORY)  MISC  http://sec.org.il/coverages.php?c=89
http://forums.miranda-im.org/showthread.php?t=1070
(VENDOR_ADVISORY)  MISC  http://forums.miranda-im.org/showthread.php?t=1070

- 漏洞信息

针对Miranda Instant Messenger的PopUp Plus远程缓冲区溢出漏洞
高危 缓冲区溢出
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        针对Miranda IM的PopUp Plus 2.0.3.8插件在启用"Use SmileyAdd Setting"的情况下,其存在的缓冲区溢出漏洞允许远程攻击者执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://files.miranda-im.org/testing/popupplus.zip"

- 漏洞信息

15482
Miranda IM PopUp Plus Plugin Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-04-06 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.3.9 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: Disable smiley support.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PopUp Plus For Miranda Instant Messenger Remote Buffer Overflow Vulnerability
Boundary Condition Error 13048
Yes No
2005-04-06 12:00:00 2009-07-12 12:56:00
editor@sec.org.il is credited with the discovery of this issue.

- 受影响的程序版本

PopUp Plus Plugin For Miranda Instant Messenger 2.0.3.8

- 漏洞讨论

A remote buffer overflow vulnerability affects PopUp Plus for Miranda Instant Messenger. This issue is due to a failure of the application to properly validate the length of user-supplied strings prior to copying them into static process buffers.

An attacker may exploit this issue to execute arbitrary code with the privileges of the user that activated the vulnerable application. This may facilitate unauthorized access or privilege escalation.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

The vendor has released the following fix:


PopUp Plus Plugin For Miranda Instant Messenger 2.0.3.8

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站