CVE-2005-1078
CVSS7.5
发布时间 :2005-04-12 00:00:00
修订时间 :2016-10-17 23:17:05
NMCOS    

[原文]XAMPP 1.4.x has multiple default or null passwords, which allows attackers to gain privileges.


[CNNVD]XAMPP不安全默认密码泄露漏洞(CNNVD-200504-017)

        XAMPP(Apache+MySQL+PHP+PERL)是一个功能强大的建站集成软件包。这个软件包原来的名字是LAMPP,但是为了避免误解,最新的几个版本就改名为 XAMPP 了。它可以在Windows、Linux、Solaris三种操作系统下安装使用,支持多语言:英文、简体中文、繁体中文、韩文、俄文、日文等。XAMPP 是一个易于安装且包含 MySQL、PHP 和 Perl 的 Apache 发行版。
        XAMPP 1.4.x有多个默认或空密码,攻击者可借此获取权限。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:xampp:apache_distribution:1.4.10a
cpe:/a:xampp:apache_distribution:1.4.9
cpe:/a:xampp:apache_distribution:0.1::solaris
cpe:/a:xampp:apache_distribution:1.4.4
cpe:/a:xampp:apache_distribution:1.4.7
cpe:/a:xampp:apache_distribution:1.4.5
cpe:/a:xampp:apache_distribution:1.4.3
cpe:/a:xampp:apache_distribution:1.4.6
cpe:/a:xampp:apache_distribution:1.4.1
cpe:/a:xampp:apache_distribution:1.4.2
cpe:/a:xampp:apache_distribution:0.2::solaris
cpe:/a:xampp:apache_distribution:0.3::solaris
cpe:/a:xampp:apache_distribution:1.4.13
cpe:/a:xampp:apache_distribution:1.4.11
cpe:/a:xampp:apache_distribution:1.4.10
cpe:/a:xampp:apache_distribution:1.4.12
cpe:/a:xampp:apache_distribution:1.4.8

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1078
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1078
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200504-017
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=full-disclosure&m=111330048629182&w=2
(UNKNOWN)  FULLDISC  20050412 XAMPP
http://www.securityfocus.com/bid/13131
(VENDOR_ADVISORY)  BID  13131

- 漏洞信息

XAMPP不安全默认密码泄露漏洞
高危 访问验证错误
2005-04-12 00:00:00 2005-10-20 00:00:00
远程  
        XAMPP(Apache+MySQL+PHP+PERL)是一个功能强大的建站集成软件包。这个软件包原来的名字是LAMPP,但是为了避免误解,最新的几个版本就改名为 XAMPP 了。它可以在Windows、Linux、Solaris三种操作系统下安装使用,支持多语言:英文、简体中文、繁体中文、韩文、俄文、日文等。XAMPP 是一个易于安装且包含 MySQL、PHP 和 Perl 的 Apache 发行版。
        XAMPP 1.4.x有多个默认或空密码,攻击者可借此获取权限。

- 公告与补丁

        暂无数据

- 漏洞信息

15636
XAMPP Multiple Default Account/Passwords
Local / Remote Authentication Management
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-04-12 Unknow
2005-04-12 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

XAMPP Insecure Default Password Disclosure Vulnerability
Access Validation Error 13131
Yes No
2005-04-12 12:00:00 2009-07-12 12:56:00
Morning Wood <se_cur_ity@hotmail.com> is credited with the discovery of these issues.

- 受影响的程序版本

XAMPP Apache Distribution for Solaris 0.3
XAMPP Apache Distribution for Solaris 0.2
XAMPP Apache Distribution for Solaris 0.1
XAMPP Apache Distribution 1.4.13
XAMPP Apache Distribution 1.4.12
XAMPP Apache Distribution 1.4.11
XAMPP Apache Distribution 1.4.10 a
XAMPP Apache Distribution 1.4.10
XAMPP Apache Distribution 1.4.9
XAMPP Apache Distribution 1.4.8
XAMPP Apache Distribution 1.4.7
XAMPP Apache Distribution 1.4.6
XAMPP Apache Distribution 1.4.5
XAMPP Apache Distribution 1.4.4
XAMPP Apache Distribution 1.4.3
XAMPP Apache Distribution 1.4.2
XAMPP Apache Distribution 1.4.1

- 漏洞讨论

An insecure default password disclosure vulnerability affects XAMPP. This issue is due to a failure of the application to properly secure access to default passwords.

An attacker may leverage this issue to gain access to the default passwords for many utilities installed by the affected application, including the MySQL 'root' user, the phpMyAdmin 'pma' user, the FTP 'nobody' user and the Tomcat administrator.

- 漏洞利用

No exploit is required to leverage this issue. The following URI will be available by default on affected computers:

http://www.example.com/xampp/security.php

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站