发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:48:08

[原文]Cross-site scripting (XSS) vulnerability in the discussion board functionality for WebCT Campus Edition 4.1 allows remote attackers to inject arbitrary web script or HTML via the message field.

[CNNVD]WebCT Discussion Board 跨站脚本攻击漏洞(CNNVD-200505-402)

        WebCT Campus Edition 4.1的discussion board函数中存在跨站脚本攻击(XSS)漏洞,允许远程攻击者通过message字段注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  13101
(VENDOR_ADVISORY)  BUGTRAQ  20050411 WebCT 4.1 vulnerable to XSS attacks

- 漏洞信息

WebCT Discussion Board 跨站脚本攻击漏洞
中危 跨站脚本
2005-05-02 00:00:00 2006-05-01 00:00:00
        WebCT Campus Edition 4.1的discussion board函数中存在跨站脚本攻击(XSS)漏洞,允许远程攻击者通过message字段注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

WebCT Discussion Board Message Field XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-04-11 Unknow
2005-04-11 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

WebCT Discussion Board HTML Injection Vulnerability
Input Validation Error 13101
Yes No
2005-04-11 12:00:00 2009-07-12 12:56:00
Discovery of this vulnerability is credited to <>.

- 受影响的程序版本

WebCT WebCT Campus Edition 4.1

- 漏洞讨论

WebCT is reportedly affected by an HTML injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input prior to using it in dynamically generated content.

Attacker-supplied HTML and script code would be able to access properties of the site, potentially allowing for theft of cookie-based authentication credentials. An attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible.

This issue is reported to affect WebCT Version 4.1; other versions may also be affected.

- 漏洞利用

No exploit is required.

The following proof of concept demonstrates a message field body suitable to exploit the vulnerability:

&lt;/pre&gt;&lt;table background=java&amp;#x09;script:alert("XSS Warning")&gt;

- 解决方案

The vendor has issued an advisory describing how to prevent this issue, please see the referenced advisory for further details.

- 相关参考