[原文]Multiple cross-site scripting (XSS) vulnerabilities in orderwiz.php in ModernBill 4.3.0 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) c_code or (2) aid parameters.
ModernBill contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'c_code' or 'aid' variables upon submission to the orderwiz.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.
Upgrade to version 4.3.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.
ModernBill is affected by a cross-site scripting vulnerability.
This issue is due to a failure in the application to properly sanitize user-supplied input to the 'aid' parameter. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.
ModernBill 4.3 and prior versions are vulnerable to this issue.
No exploit is required.
The following proof of concept URI is available: http://www.example.com/order/orderwiz.php?v=1&aid=[XSS]
The vendor has released ModernBill version 4.3.1 to address this issue. Please contact the vendor to obtain the fixed packages.