发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:16:57

[原文]Multiple cross-site scripting (XSS) vulnerabilities in orderwiz.php in ModernBill 4.3.0 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) c_code or (2) aid parameters.

[CNNVD]ModernGigabyte ModernBill Aid参数跨站脚本漏洞(CNNVD-200505-149)

        ModernBill 4.3.0及更早版本的orderwiz.php中的多个跨站脚本攻击(XSS)漏洞,可让远程攻击者通过(1)c_code或(2)aid参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20050410 Multiple ModernBill 4.3.0 And Earlier Vulnerabilities
(PATCH)  SECTRACK  1013672
(UNKNOWN)  XF  modernbill-orderwiz-xss(20035)

- 漏洞信息

ModernGigabyte ModernBill Aid参数跨站脚本漏洞
中危 跨站脚本
2005-05-02 00:00:00 2006-09-21 00:00:00
        ModernBill 4.3.0及更早版本的orderwiz.php中的多个跨站脚本攻击(XSS)漏洞,可让远程攻击者通过(1)c_code或(2)aid参数注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

ModernBill orderwiz.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

ModernBill contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'c_code' or 'aid' variables upon submission to the orderwiz.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-04-10 Unknow
2005-04-10 Unknow

- 解决方案

Upgrade to version 4.3.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

ModernGigabyte ModernBill Aid Parameter Cross-Site Scripting Vulnerability
Input Validation Error 13089
Yes No
2005-04-11 12:00:00 2009-07-12 12:56:00
Discovery is credited to James Bercegay of the GulfTech Security Research Team.

- 受影响的程序版本

ModernGigabyte ModernBill 4.3
ModernGigabyte ModernBill 4.3.1

- 不受影响的程序版本

ModernGigabyte ModernBill 4.3.1

- 漏洞讨论

ModernBill is affected by a cross-site scripting vulnerability.

This issue is due to a failure in the application to properly sanitize user-supplied input to the 'aid' parameter. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

ModernBill 4.3 and prior versions are vulnerable to this issue.

- 漏洞利用

No exploit is required.

The following proof of concept URI is available:[XSS]

- 解决方案

The vendor has released ModernBill version 4.3.1 to address this issue. Please contact the vendor to obtain the fixed packages.

- 相关参考