CVE-2005-1027
CVSS4.3
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:16:40
NMCOS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in PHP-Nuke 6.x through 7.6 allow remote attackers to inject arbitrary web script or HTML via the (1) username parameter in the Your_Account module, (2) avatarcategory parameter in the Your_Account module, or (3) lid parameter in the Downloads module.


[CNNVD]PHP-Nuke Your_Account 跨站脚本攻击漏洞(CNNVD-200505-408)

        PHP-Nuke 6.x至7.6中的多个跨站脚本攻击(XSS)漏洞,允许远程攻击者通过(1)Your_Account模块的username参数,(2)Your_Account模块的avatarcategory参数或者(3)Downloads模块的lid参数来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:francisco_burzi:php-nuke:7.2
cpe:/a:francisco_burzi:php-nuke:6.0
cpe:/a:francisco_burzi:php-nuke:7.0
cpe:/a:francisco_burzi:php-nuke:6.6
cpe:/a:francisco_burzi:php-nuke:7.5
cpe:/a:francisco_burzi:php-nuke:6.5_rc1
cpe:/a:francisco_burzi:php-nuke:7.1
cpe:/a:francisco_burzi:php-nuke:7.0_final
cpe:/a:francisco_burzi:php-nuke:6.5_rc2
cpe:/a:francisco_burzi:php-nuke:6.9
cpe:/a:francisco_burzi:php-nuke:6.5_beta1
cpe:/a:francisco_burzi:php-nuke:6.5_rc3
cpe:/a:francisco_burzi:php-nuke:6.7
cpe:/a:francisco_burzi:php-nuke:7.6
cpe:/a:francisco_burzi:php-nuke:7.3
cpe:/a:francisco_burzi:php-nuke:6.5
cpe:/a:francisco_burzi:php-nuke:7.4
cpe:/a:francisco_burzi:php-nuke:6.5_final

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-1027
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-1027
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-408
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111272010303144&w=2
(UNKNOWN)  BUGTRAQ  20050404 [SECURITYREASON.COM] Full path disclosure and XSS in PHPNuke part 3
http://www.securityfocus.com/archive/1/321324
(UNKNOWN)  BUGTRAQ  20030511 PHPNuke "Your Account" XSS Vulnerability
http://www.securityfocus.com/bid/7570
(UNKNOWN)  BID  7570
http://xforce.iss.net/xforce/xfdb/11994
(UNKNOWN)  XF  phpnuke-modules-xss(11994)

- 漏洞信息

PHP-Nuke Your_Account 跨站脚本攻击漏洞
中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        PHP-Nuke 6.x至7.6中的多个跨站脚本攻击(XSS)漏洞,允许远程攻击者通过(1)Your_Account模块的username参数,(2)Your_Account模块的avatarcategory参数或者(3)Downloads模块的lid参数来注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

15403
PHP-Nuke Downloads Module lid Parameter XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

PHP-Nuke contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'lid' variables upon submission to the 'Downloads' module. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-04-05 Unknow
2005-04-05 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

PHP-Nuke Downloads Module Lid Parameter Cross-Site Scripting Vulnerability
Input Validation Error 13011
Yes No
2005-04-05 12:00:00 2009-07-12 11:56:00
Discovery of this issues is credited to sp3x <sp3x@securityreason.com>.

- 受影响的程序版本

Francisco Burzi PHP-Nuke 7.6
Francisco Burzi PHP-Nuke 7.3
Francisco Burzi PHP-Nuke 7.3
Francisco Burzi PHP-Nuke 7.2
Francisco Burzi PHP-Nuke 7.1
Francisco Burzi PHP-Nuke 7.0 FINAL
Francisco Burzi PHP-Nuke 7.0
Francisco Burzi PHP-Nuke 6.9
Francisco Burzi PHP-Nuke 6.7
Francisco Burzi PHP-Nuke 6.6
Francisco Burzi PHP-Nuke 6.5 RC3
Francisco Burzi PHP-Nuke 6.5 RC2
Francisco Burzi PHP-Nuke 6.5 RC1
Francisco Burzi PHP-Nuke 6.5 FINAL
Francisco Burzi PHP-Nuke 6.5 BETA 1
Francisco Burzi PHP-Nuke 6.5
Francisco Burzi PHP-Nuke 6.0

- 漏洞讨论

It is reported that the PHP-Nuke 'Downloads' module is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This problem presents itself when malicious HTML and script code is sent to the application through the 'Downloads' module.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials.

This vulnerability is reported to affect PHP-Nuke version 7.6 and previous versions.

- 漏洞利用

The following example is available:

http://www.example.com/[nuke_dir]/modules.php?name=Downloads&amp;d_op=outsidedownloadsetup&amp;lid=[XSS]

To test XSS for example in http://www.example.com/[nuke_dir]/modules.php?name=Downloads&amp;d_op=outsidedownloadsetup&amp;lid=[XSS] we can
create a form.

test.html :
-----------
&lt;form name="mantra" method="POST" action="http://www.example.com/[nuke_dir]/modules.php"&gt;
&lt;p&gt;XSS:
&lt;input type="text" name="lid"&gt;
&lt;br&gt;
&lt;input type="hidden" name="name" value="Downloads"&gt;
&lt;br&gt;
&lt;input type="hidden" name="d_op" value="outsidedownloadsetup"&gt;
&lt;/p&gt;
&lt;p&gt;
&lt;input type="submit" name="Submit" value="Go!"&gt;
&lt;br&gt;
&lt;/p&gt;

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站