CVE-2005-0993
CVSS4.6
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:16:18
NMCOS    

[原文]Buffer overflow in nwprint in SCO OpenServer 5.0.7 allows local users to execute arbitrary code via a long command line argument.


[CNNVD]SCO OpenServer NWPrint缓冲区溢出漏洞(CNNVD-200505-316)

        SCO OpenServer是中小企业业务最流行的UNIX服务器平台。
        SCO OpenServer捆绑的nwprint存在本地缓冲区溢出漏洞,本地攻击者可能利用此漏洞提升权限。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sco:openserver:5.0.6
cpe:/o:sco:openserver:5.0.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0993
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0993
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-316
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111263251718491&w=2
(UNKNOWN)  BUGTRAQ  20050404 possible privilege escalation on Sco OpenServer 5.0.7
http://www.securityfocus.com/bid/12986
(PATCH)  BID  12986

- 漏洞信息

SCO OpenServer NWPrint缓冲区溢出漏洞
中危 缓冲区溢出
2005-05-02 00:00:00 2005-10-20 00:00:00
本地  
        SCO OpenServer是中小企业业务最流行的UNIX服务器平台。
        SCO OpenServer捆绑的nwprint存在本地缓冲区溢出漏洞,本地攻击者可能利用此漏洞提升权限。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        www.caldera.com/products/openserver/

- 漏洞信息

15274
SCO OpenServer nwprint Command Line Local Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-04-03 Unknow
2005-04-03 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SCO OpenServer NWPrint Command Line Argument Local Buffer Overflow Vulnerability
Boundary Condition Error 12986
No Yes
2005-04-04 12:00:00 2009-07-12 11:56:00
Discovery of this vulnerability is credited to pasquale minervini <minervini@neuralnoise.com>.

- 受影响的程序版本

SCO Open Server 5.0.7
SCO Open Server 5.0.6

- 漏洞讨论

nwprint that is distributed with SCO OpenServer is prone to a local buffer overflow vulnerability. This issue arises because the application fails to perform boundary checks prior to copying user-supplied data into sensitive process buffers. A local attacker can gain elevated privileges (lp user) by exploiting this issue.

- 漏洞利用

The following exploit is available:

- 解决方案

SCO has released security advisory SCOSA-2005.26 addressing this issue. Please see the referenced advisory for details on obtaining and applying the appropriate updates.


SCO Open Server 5.0.6

SCO Open Server 5.0.7

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站