CVE-2005-0992
CVSS4.3
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:16:17
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in index.php in phpMyAdmin before 2.6.2-rc1 allows remote attackers to inject arbitrary web script or HTML via the convcharset parameter.


[CNNVD]PHPMyAdmin Convcharset 跨站脚本漏洞(CNNVD-200505-487)

        phpMyAdmin 2.6.2-rc1之前版本的index.php中存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助convcharset参数注入任意的Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpmyadmin:phpmyadmin:2.2.5
cpe:/a:phpmyadmin:phpmyadmin:2.5.2
cpe:/a:phpmyadmin:phpmyadmin:2.6.1
cpe:/a:phpmyadmin:phpmyadmin:2.2.4
cpe:/a:phpmyadmin:phpmyadmin:2.5.1
cpe:/a:phpmyadmin:phpmyadmin:2.5.4
cpe:/a:phpmyadmin:phpmyadmin:2.2.6
cpe:/a:phpmyadmin:phpmyadmin:2.5.3
cpe:/a:phpmyadmin:phpmyadmin:2.5.5_rc2
cpe:/a:phpmyadmin:phpmyadmin:2.5.5_rc1
cpe:/a:phpmyadmin:phpmyadmin:2.5.5_pl1
cpe:/a:phpmyadmin:phpmyadmin:2.0.1
cpe:/a:phpmyadmin:phpmyadmin:2.0.3
cpe:/a:phpmyadmin:phpmyadmin:2.1.2
cpe:/a:phpmyadmin:phpmyadmin:2.0.2
cpe:/a:phpmyadmin:phpmyadmin:2.1.1
cpe:/a:phpmyadmin:phpmyadmin:2.0.5
cpe:/a:phpmyadmin:phpmyadmin:2.2.3
cpe:/a:phpmyadmin:phpmyadmin:2.3.2
cpe:/a:phpmyadmin:phpmyadmin:2.5.0
cpe:/a:phpmyadmin:phpmyadmin:2.0.4
cpe:/a:phpmyadmin:phpmyadmin:2.2.2
cpe:/a:phpmyadmin:phpmyadmin:2.3.1
cpe:/a:phpmyadmin:phpmyadmin:2.4.0
cpe:/a:phpmyadmin:phpmyadmin:2.5.6_rc1
cpe:/a:phpmyadmin:phpmyadmin:2.6.1_rc1
cpe:/a:phpmyadmin:phpmyadmin:2.2_rc2
cpe:/a:phpmyadmin:phpmyadmin:2.2_rc3
cpe:/a:phpmyadmin:phpmyadmin:2.6.1_pl3
cpe:/a:phpmyadmin:phpmyadmin:2.2
cpe:/a:phpmyadmin:phpmyadmin:2.1
cpe:/a:phpmyadmin:phpmyadmin:2.0
cpe:/a:phpmyadmin:phpmyadmin:2.2_rc1
cpe:/a:phpmyadmin:phpmyadmin:2.6.1_pl1
cpe:/a:phpmyadmin:phpmyadmin:2.5.5
cpe:/a:phpmyadmin:phpmyadmin:2.5.7
cpe:/a:phpmyadmin:phpmyadmin:2.5.7_pl1
cpe:/a:phpmyadmin:phpmyadmin:2.6.0_pl3
cpe:/a:phpmyadmin:phpmyadmin:2.2_pre2
cpe:/a:phpmyadmin:phpmyadmin:2.6.0_pl2
cpe:/a:phpmyadmin:phpmyadmin:2.6.0_pl1
cpe:/a:phpmyadmin:phpmyadmin:2.2_pre1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0992
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0992
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-487
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111264361622660&w=2
(UNKNOWN)  BUGTRAQ  20050404 phpMyAdmin Cross-site Scripting Vulnerability
http://www.arrelnet.com/advisories/adv20050403.html
(VENDOR_ADVISORY)  MISC  http://www.arrelnet.com/advisories/adv20050403.html
http://www.gentoo.org/security/en/glsa/glsa-200504-08.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200504-08
http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2005-3
(VENDOR_ADVISORY)  CONFIRM  http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2005-3
http://www.securityfocus.com/bid/12982
(PATCH)  BID  12982
http://xforce.iss.net/xforce/xfdb/19940
(PATCH)  XF  phpmyadmin-convcharset-xss(19940)

- 漏洞信息

PHPMyAdmin Convcharset 跨站脚本漏洞
中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        phpMyAdmin 2.6.2-rc1之前版本的index.php中存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助convcharset参数注入任意的Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        phpMyAdmin phpMyAdmin 2.0
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.0.1
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.0.2
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.0.3
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.0.4
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.0.5
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.1 .2
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.1
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.1 .1
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.2 pre1
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.2 rc3
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.2 pre2
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.2 rc2
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.2
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.2 rc1
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.2.2
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.2.3
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.2.4
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.2.5
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.2.6
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.3.1
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.3.2
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.4 .0
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.5 .0
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.5.1
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.tar .gz?download
        phpMyAdmin phpMyAdmin 2.5.2
        phpMyAdmin phpMyAdmin-2.6.2-rc1.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.2-rc1.t

- 漏洞信息

15226
phpMyAdmin index.php convcharset Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-04-04 Unknow
2005-04-04 Unknow

- 解决方案

Upgrade to version 2.6.2-rc1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHPMyAdmin Convcharset Cross-Site Scripting Vulnerability
Input Validation Error 12982
Yes No
2005-04-03 12:00:00 2007-01-12 10:30:00
Discovery is credited to Oriol Torrent Santiago <oriol.torrent@gmail.com>.

- 受影响的程序版本

phpMyAdmin phpMyAdmin 2.6.1 pl3
phpMyAdmin phpMyAdmin 2.6.1 pl1
phpMyAdmin phpMyAdmin 2.6.1 -rc1
phpMyAdmin phpMyAdmin 2.6.1
phpMyAdmin phpMyAdmin 2.6 .0pl3
phpMyAdmin phpMyAdmin 2.6 .0pl2
+ Gentoo Linux 1.4
+ Gentoo Linux
+ Gentoo Linux
+ Gentoo Linux
phpMyAdmin phpMyAdmin 2.6 .0pl1
phpMyAdmin phpMyAdmin 2.5.7 pl1
phpMyAdmin phpMyAdmin 2.5.7
phpMyAdmin phpMyAdmin 2.5.6 -rc1
phpMyAdmin phpMyAdmin 2.5.5 pl1
phpMyAdmin phpMyAdmin 2.5.5 -rc2
phpMyAdmin phpMyAdmin 2.5.5 -rc1
phpMyAdmin phpMyAdmin 2.5.5
phpMyAdmin phpMyAdmin 2.5.4
phpMyAdmin phpMyAdmin 2.5.3
+ S.u.S.E. Linux Personal 9.3
+ S.u.S.E. Linux Personal 9.2 x86_64
+ S.u.S.E. Linux Personal 9.2 x86_64
+ S.u.S.E. Linux Personal 9.2 x86_64
+ S.u.S.E. Linux Personal 9.2
+ S.u.S.E. Linux Personal 9.2
+ S.u.S.E. Linux Personal 9.2
+ S.u.S.E. Linux Personal 9.1 x86_64
+ S.u.S.E. Linux Personal 9.1 x86_64
+ S.u.S.E. Linux Personal 9.1 x86_64
+ S.u.S.E. Linux Personal 9.1
+ S.u.S.E. Linux Personal 9.1
+ S.u.S.E. Linux Personal 9.1
+ S.u.S.E. Linux Personal 9.0 x86_64
+ S.u.S.E. Linux Personal 9.0 x86_64
+ S.u.S.E. Linux Personal 9.0 x86_64
+ S.u.S.E. Linux Personal 9.0
+ S.u.S.E. Linux Personal 9.0
+ S.u.S.E. Linux Personal 9.0
phpMyAdmin phpMyAdmin 2.5.2
phpMyAdmin phpMyAdmin 2.5.1
phpMyAdmin phpMyAdmin 2.5 .0
phpMyAdmin phpMyAdmin 2.4 .0
phpMyAdmin phpMyAdmin 2.3.2
phpMyAdmin phpMyAdmin 2.3.1
phpMyAdmin phpMyAdmin 2.2.6
phpMyAdmin phpMyAdmin 2.2.5
phpMyAdmin phpMyAdmin 2.2.4
phpMyAdmin phpMyAdmin 2.2.3
phpMyAdmin phpMyAdmin 2.2.2
phpMyAdmin phpMyAdmin 2.2 rc3
phpMyAdmin phpMyAdmin 2.2 rc2
phpMyAdmin phpMyAdmin 2.2 rc1
phpMyAdmin phpMyAdmin 2.2 pre2
phpMyAdmin phpMyAdmin 2.2 pre1
phpMyAdmin phpMyAdmin 2.2
phpMyAdmin phpMyAdmin 2.1 .2
phpMyAdmin phpMyAdmin 2.1 .1
phpMyAdmin phpMyAdmin 2.1
- Debian Linux 2.2 sparc
- Debian Linux 2.2 sparc
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 arm
- Debian Linux 2.2 arm
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 alpha
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- Debian Linux 2.2 68k
- Debian Linux 2.2 68k
- Debian Linux 2.2
- Debian Linux 2.2
- Debian Linux 2.2
- FreeBSD FreeBSD 4.2
- FreeBSD FreeBSD 4.2
- FreeBSD FreeBSD 4.2
- FreeBSD FreeBSD 3.5.1
- FreeBSD FreeBSD 3.5.1
- FreeBSD FreeBSD 3.5.1
- Mandriva Linux Mandrake 7.2
- Mandriva Linux Mandrake 7.2
- Mandriva Linux Mandrake 7.2
- Mandriva Linux Mandrake 7.1
- Mandriva Linux Mandrake 7.1
- Mandriva Linux Mandrake 7.1
- Mandriva Linux Mandrake 7.0
- Mandriva Linux Mandrake 7.0
- Mandriva Linux Mandrake 7.0
- OpenBSD OpenBSD 2.8
- OpenBSD OpenBSD 2.8
- OpenBSD OpenBSD 2.8
- OpenBSD OpenBSD 2.7
- OpenBSD OpenBSD 2.7
- OpenBSD OpenBSD 2.7
- OpenBSD OpenBSD 2.6
- OpenBSD OpenBSD 2.6
- OpenBSD OpenBSD 2.6
- Red Hat Linux 6.2
- Red Hat Linux 6.2
- Red Hat Linux 6.2
- RedHat Linux 7.0
- RedHat Linux 7.0
- RedHat Linux 7.0
- S.u.S.E. Linux 7.1
- S.u.S.E. Linux 7.0
- S.u.S.E. Linux 7.0
- S.u.S.E. Linux 7.0
- S.u.S.E. Linux 6.4
- S.u.S.E. Linux 6.4
- S.u.S.E. Linux 6.4
- Sun Solaris 8_x86
- Sun Solaris 8_x86
- Sun Solaris 8_x86
- Sun Solaris 8_sparc
- Sun Solaris 8_sparc
- Sun Solaris 8_sparc
- Sun Solaris 7.0_x86
- Sun Solaris 7.0_x86
- Sun Solaris 7.0_x86
- Sun Solaris 7.0
- Sun Solaris 7.0
- Sun Solaris 7.0
- Sun Solaris 2.6_x86
- Sun Solaris 2.6_x86
- Sun Solaris 2.6_x86
- Sun Solaris 2.6
- Sun Solaris 2.6
- Sun Solaris 2.6
phpMyAdmin phpMyAdmin 2.0.5
phpMyAdmin phpMyAdmin 2.0.4
phpMyAdmin phpMyAdmin 2.0.3
phpMyAdmin phpMyAdmin 2.0.2
phpMyAdmin phpMyAdmin 2.0.1
phpMyAdmin phpMyAdmin 2.0
phpMyAdmin phpMyAdmin 2.6.2 -rc1

- 不受影响的程序版本

phpMyAdmin phpMyAdmin 2.6.2 -rc1

- 漏洞讨论

phpMyAdmin is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input to the 'convcharset' parameter.

phpMyAdmin versions prior to 2.6.2-rc1 are affected by this issue.

- 漏洞利用

No exploit is required.

The following proof-of-concept URIs are available:

http://www.example.com/phpmyadmin/index.php?pma_username=&pma_password=&server=1&lang=en-iso-8859-1&convcharset=\"><script>alert(document.cookie)</script>

http://www.example.com/phpmyadmin/index.php?pma_username=&pma_password=&server=1&lang=en-iso-8859-1&convcharset=\"><h1>XSS</h1>

- 解决方案

Please see the referenced advisories for more information.


phpMyAdmin phpMyAdmin 2.0

phpMyAdmin phpMyAdmin 2.0.1

phpMyAdmin phpMyAdmin 2.0.2

phpMyAdmin phpMyAdmin 2.0.3

phpMyAdmin phpMyAdmin 2.0.4

phpMyAdmin phpMyAdmin 2.0.5

phpMyAdmin phpMyAdmin 2.1 .2

phpMyAdmin phpMyAdmin 2.1

phpMyAdmin phpMyAdmin 2.1 .1

phpMyAdmin phpMyAdmin 2.2 pre1

phpMyAdmin phpMyAdmin 2.2 rc3

phpMyAdmin phpMyAdmin 2.2 pre2

phpMyAdmin phpMyAdmin 2.2 rc2

phpMyAdmin phpMyAdmin 2.2

phpMyAdmin phpMyAdmin 2.2 rc1

phpMyAdmin phpMyAdmin 2.2.2

phpMyAdmin phpMyAdmin 2.2.3

phpMyAdmin phpMyAdmin 2.2.4

phpMyAdmin phpMyAdmin 2.2.5

phpMyAdmin phpMyAdmin 2.2.6

phpMyAdmin phpMyAdmin 2.3.1

phpMyAdmin phpMyAdmin 2.3.2

phpMyAdmin phpMyAdmin 2.4 .0

phpMyAdmin phpMyAdmin 2.5 .0

phpMyAdmin phpMyAdmin 2.5.1

phpMyAdmin phpMyAdmin 2.5.2

phpMyAdmin phpMyAdmin 2.5.4

phpMyAdmin phpMyAdmin 2.5.5 -rc2

phpMyAdmin phpMyAdmin 2.5.5 -rc1

phpMyAdmin phpMyAdmin 2.5.5

phpMyAdmin phpMyAdmin 2.5.5 pl1

phpMyAdmin phpMyAdmin 2.5.6 -rc1

phpMyAdmin phpMyAdmin 2.5.7

phpMyAdmin phpMyAdmin 2.5.7 pl1

phpMyAdmin phpMyAdmin 2.6 .0pl2

phpMyAdmin phpMyAdmin 2.6 .0pl1

phpMyAdmin phpMyAdmin 2.6 .0pl3

phpMyAdmin phpMyAdmin 2.6.1 pl3

phpMyAdmin phpMyAdmin 2.6.1 pl1

phpMyAdmin phpMyAdmin 2.6.1 -rc1

phpMyAdmin phpMyAdmin 2.6.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站