CVE-2005-0984
CVSS5.0
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:16:15
NMCOS    

[原文]Buffer overflow in the G_Printf function in Star Wars Jedi Knight: Jedi Academy 1.011 and earlier allows remote attackers to execute arbitrary code via a long message using commands such as (1) say and (2) tell.


[CNNVD]Star Wars Jedi Knight: Jedi Academy缓冲区溢出漏洞(CNNVD-200505-591)

        游戏在处理打印字串时存在溢出漏洞,远程攻击者可能利用此漏洞在主机上执行任意指令。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0984
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0984
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-591
(官方数据源) CNNVD

- 其它链接及资源

http://aluigi.altervista.org/adv/jamsgbof-adv.txt
(VENDOR_ADVISORY)  MISC  http://aluigi.altervista.org/adv/jamsgbof-adv.txt
http://marc.info/?l=bugtraq&m=111246855213653&w=2
(UNKNOWN)  BUGTRAQ  20050402 In-game server buffer-overflow in Jedi Academy 1.011
http://www.securityfocus.com/bid/12977
(UNKNOWN)  BID  12977

- 漏洞信息

Star Wars Jedi Knight: Jedi Academy缓冲区溢出漏洞
中危 缓冲区溢出
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        游戏在处理打印字串时存在溢出漏洞,远程攻击者可能利用此漏洞在主机上执行任意指令。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.lucasarts.com

- 漏洞信息

15230
Star Wars Jedi Academy Message Handling Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

A remote overflow exists in Star Wars Jedi Knight: Jedi Academy. The 'G_Printf()' function fails to perform proper bounds checking resulting in a buffer overflow. With an overly long message, a remote attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-04-02 Unknow
2005-04-02 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Star Wars Jedi Knight: Jedi Academy Buffer Overflow Vulnerability
Boundary Condition Error 12977
Yes No
2005-04-02 12:00:00 2009-07-12 11:56:00
Discovered by Luigi Auriemma <aluigi@..>.

- 受影响的程序版本

LucasArts Star Wars Jedi Knight: Jedi Academy 1.0.11

- 漏洞讨论

A buffer overflow is present in Jedi Academy that can be exploited remotely by client systems. The overflow is due to the use of the sprintf() function in a text visualization procedure, G_Printf(). The attacker can exploit this vulnerability to execute arbitrary code on the server.

- 漏洞利用

The advisory describing this vulnerability published by Luigi Auriemma outlined the following steps for exploitation:

- download the following file:
jamsgbof.cfg
- place it in the base folder of the game: GameData\base
- start a client and a server
- join the server
- go into the client console (shift + ~)
- type: /exec jamsgbof
- the server will crash with the return address overwritten with
0x61616161

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站